Opened 12 years ago

Closed 12 years ago

#1002 closed defect (wontfix)

mp3lib converts mono files to stereo

Reported by: aflist2@… Owned by: r_togni@…
Priority: normal Component: ad
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

hello,

playing a file with the default mp3lib decoder converts mono files to stereo.
using -ac ffmp3/mad have correct behavior and keep the sound mono.

file decodertest.mp3

decodertest.mp3: MPEG ADTS, layer III, v1, 128 kBits, 48 kHz, Monaural

MPlayer dev-SVN-r25826-4.2.3 (C) 2000-2008 MPlayer Team
CPU: AMD Athlon(tm) XP 2100+ (Family: 6, Model: 6, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE
117 audio & 238 video codecs

Playing decodertest.mp3.
Audio file file format detected.
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 2.0 (01.9) of 1.0 (01.0) 0.6%
Exiting... (Quit)

Attachments (1)

decodertest.mp3 (24.3 KB) - added by aflist2@… 12 years ago.
test file (mono)

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by aflist2@…

test file (mono)

comment:1 Changed 12 years ago by aflist2@…

comment:2 Changed 12 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

mp3lib supports only 2-channel output.
This is not a bug but simply the normal behaviour.

Note: See TracTickets for help on using tickets.