Opened 12 years ago

Last modified 9 years ago

#1004 closed defect (worksforme)

mplayer can't use number pad keys

Reported by: aflist2@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

hello,

i'd like to bind some functions to my number pad keys. mplayer seems to be misidentifying number pad keys.

i'm testing using KP4/KP_Left. xev correctly identifies the key.
numlock off:
state 0x0, keycode 83 (keysym 0xff96, KP_Left), same_screen YES,
numlock on:
state 0x10, keycode 83 (keysym 0xffb4, KP_4), same_screen YES,

with numlock on, mplayer processes it as the regular "4" above the qwerty. with numlock off, the key is misidentifed as two keypresses, always together. the single quote after the period is always missing.

VO: [xv] 512x384 => 512x384 Planar YV12 [fs]
No bind found for key '. 13% 6% 1.3% 0 0
No bind found for key 'O'. % 6% 1.3% 0 0
A: 4.2 V: 4.2 A-V: 0.000 ct: -0.000 126/126 12% 6% 1.3% 0 0

MPlayer dev-SVN-r25826-4.2.3

Change History (5)

comment:1 Changed 12 years ago by reimar

No such problem here. When the console window has focus numpad either behaves like cursor key or numbers, depending on numlock, when the playback window has focus it detects the KP* events.
Your description sounds to me like your console window had focus and this one does not handle the cursor keys quite right (or at least not in a way MPlayer likes).

comment:2 Changed 12 years ago by aflist2@…

hello,

i tested and mplayer does correctly captures the key when the video window has focus.

my normal usage of mplayer displays the video on another X display where there is no mouse or window manager, so all input has to go into the mplayer console/terminal. i am using rxvt-unicode 8.9.

comment:3 Changed 12 years ago by compn

does rxvt have proper getch2 support?

i know the mingw rxvt has trouble with mplayer too... but its a crappy term anyways.

comment:4 Changed 12 years ago by reimar

I know xterm works for me, but I do not know what exactly causes the problem.
The MinGW problem is a different one, MinGW builds of MPlayer do not support vt-100 or similar input but only input the way the windows commandline provides.

comment:5 Changed 9 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed, patriotact@gmail.com

works for reimar > close bug.

Note: See TracTickets for help on using tickets.