Opened 11 years ago

Closed 11 years ago

#1005 closed defect (invalid)

OSD causes crash with certain flags enabled/disabled

Reported by: physhii@… Owned by: reimar
Priority: normal Component: vo
Version: unspecified Severity: major
Keywords: Cc: physhii@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The OSD causes a crash with certain enable/disable flags used. I've had this problem since before revision 25659 and I still have it at the current revision.

Small debug output:
Program received signal SIGILL, Illegal instruction.
0x000000000057e43c in vo_draw_alpha_yv12 ()
(gdb) back
#0 0x000000000057e43c in vo_draw_alpha_yv12 ()
#1 0x00000000005814fd in vo_draw_text ()
#2 0x00000000004bb8bb in ?? ()
#3 0x00000000004916ab in filter_video ()
#4 0x0000000000442f00 in main ()

Here's the flags I used on configure:

--disable-tv-bsdbt848 --disable-vidix-external --disable-faad-external --disable-libcdio --language=en --charset=UTF-8 --disable-ftp --disable-libnut --disable-sortsub --disable-vstream --enable-mencoder --disable-gui --disable-xshape --enable-x11 --disable-xinerama --enable-xv --disable-pvr --disable-inet6 --disable-joystick --disable-lirc --disable-live --disable-radio --disable-radio-capture --disable-radio-v4l2 --enable-unrarexec --enable-rtc --enable-smb --enable-freetype --disable-tv-v4l1 --disable-radio-v4l2 --disable-radio-bsdbt848 --disable-ladspa --disable-live --disable-pnm --disable-speex --disable-xanim --disable-libamr_nb --disable-libamr_wb --disable-libdca --disable-twolame --disable-toolame --disable-qtx --enable-real --disable-win32dll --disable-3dfx --disable-tdfxvid --disable-tdfxfb --disable-dvbhead --disable-aa --disable-directfb --disable-fbdev --disable-ggi --disable-ivtv --disable-caca --disable-mga --disable-gl --enable-sdl --disable-svga --disable-vidix-internal --disable-tga --disable-zr --disable-xvmc --disable-arts --disable-esd --disable-jack --disable-nas --disable-openal --disable-ossaudio --disable-pulse --disable-mmxext --enable-3dnow --disable-3dnowext --enable-debug=3 --enable-sse --enable-sse2 --enable-mmx --disable-altivec

Change History (2)

comment:1 Changed 11 years ago by reimar

  • Owner changed from beastd to Reimar.Doeffinger@…

Since this combination:
--enable-3dnow --disable-3dnowext --enable-sse2
AFAIK does not match any CPU in existence I'd assume this is your fault...
Otherwise you should at least make gdb show the problematic instruction...

comment:2 Changed 11 years ago by physhii@…

  • Resolution set to invalid
  • Status changed from new to closed

Yeah, I'm an idiot. Removing the 3dnow crap fixed it. Totally my fault - But I did try to fix it before coming here. Sorry for the waste of time.

Note: See TracTickets for help on using tickets.