Opened 11 years ago

Closed 11 years ago

#1009 closed defect (duplicate)

Xinerama screen choosing problem

Reported by: sgsoftware@… Owned by: beastd
Priority: normal Component: vo
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi.

Default value for the '-xineramascreen' (-1) doesn't work for me. As documentation states, this value means that mplayer window would be put on the current xinerama screen. However, window is always put on the same screen (the one which happens to have lower coordinates). I looked at the source code ('update_xinerama_info' function) and, indeed, it is not quite clear for me how is it supposed to choose the current screen, since window coordinates (vo_dx and vo_dy variables) are initially zero.

I have a vertical screens layout (i.e. one is below another). Here is an output from xrandr:

Screen 0: minimum 320 x 200, current 1280 x 1824, maximum 2000 x 2000
VGA connected 1280x1024+0+800 (normal left inverted right x axis y axis) 0mm x 0mm

1280x1024 60.0*+
1600x1200 60.0
1600x1024 60.0
1400x1050 60.0
1280x960 60.0
1152x864 75.0
1024x768 70.1 60.0
832x624 74.6
800x600 72.2 75.0 60.3 56.2
640x480 72.8 75.0 59.9

LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm

1280x800 60.0*+
1152x768 54.8
800x600 56.2
640x480 59.9

TV disconnected (normal left inverted right x axis y axis)

I run mplayer on the VGA screen, but it always appears on LVDS (unless I set xineramascreen to 0 explicitly).

Change History (1)

comment:1 Changed 11 years ago by reimar

  • Resolution set to duplicate
  • Status changed from new to closed

* This bug has been marked as a duplicate of bug 1008 *

Note: See TracTickets for help on using tickets.