Opened 12 years ago

Closed 12 years ago

#1023 closed defect (fixed)

-af option wants a list, but there are no -af-pre etc. parameters

Reported by: divVerent@… Owned by: reynaldo@…
Priority: normal Component: af
Version: HEAD Severity: trivial
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

In my mplayer config, I want to use "af = scaletempo". However, I have some per-file .conf files that also want to add their own "af" options, like, "af = volume=-1.3004dB:1". I am doing this to get something like a "format independent ReplayGain?" (some of these files are flacs, which are not supported by any replaygain tool).

Now the problem is: when two files specify "af" options, the latter takes precedence, and the former no longer works (unlike lavcopts, where multiple instances cumulate).

What I'd like is options af-add, af-pre, af-del and af-clr, just like they exist for vf... and it really can't be hard... although I did not succeed in doing that.

It looks like parse_str_list is responsible for parsing "-af" which is a CONF_TYPE_STRING_LIST, and it does support the other operations -add, -pre, -del and -clr. I then thought it would suffice to change the parameter definition for "af" into "af*", so the "longer" options actually get passed to parse_str_list, but after doing that change and recompiling, it still says -af-pre is an invalid option. But I must be missing something obvious and this is really trivial to add... so I'd like to see this in mplayer soon.

Attachments (1)

af-pre.diff (604 bytes) - added by divVerent@… 12 years ago.
Trivial af-pre patch

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by divVerent@…

Trivial af-pre patch

comment:1 Changed 12 years ago by divVerent@…

Damn... I just got it working. While making this report, I recompiled mplayer with --enable-debug=3. And after that, it worked - my added "-af-add" works fine now.

So we I think we can file this under "make clean did not work right" (and the configure run I did to add the debug option made my changes take effect). I attached the really trivial patch that makes -af-pre etc. work - and allows me to use my per-file replaygain AND scaletempo.

comment:2 Changed 12 years ago by reimar

  • Cc Reimar.Doeffinger@… added

This change breaks -af-adv

comment:3 Changed 12 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Done in a working way, including man page update.

Note: See TracTickets for help on using tickets.