Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#103 closed defect (invalid)

Problem compiling MPlayer 1.0pre5

Reported by: pierre42d@… Owned by: moritz@…
Priority: normal Component: demuxer
Version: 1.0pre5 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

# make
make -C libmpdemux
make[1]: Entering directory `/tmp/MPlayer-1.0pre5/libmpdemux'
gcc -c -I../libvo -I../../libvo -I/usr/X11/include -s -O3 -march=i686
-D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
-I/usr/local/include/gtk-1.2 -I/usr/local/include/glib-1.2
-I/usr/local/lib/glib/include -I../loader -I/usr/local/include/gtk-1.2
-I/usr/local/include/glib-1.2 -I/usr/local/lib/glib/include -o demux_ogg.o
demux_ogg.c
demux_ogg.c: In function `demux_ogg_add_sub':
demux_ogg.c:220: warning: initialization from incompatible pointer type
demux_ogg.c: In function `demux_ogg_read_packet':
demux_ogg.c:323: warning: assignment from incompatible pointer type
demux_ogg.c:324: error: invalid operands to binary &
demux_ogg.c:345: warning: assignment from incompatible pointer type
demux_ogg.c:377: error: invalid operands to binary &
demux_ogg.c:381: error: invalid operands to binary &
demux_ogg.c:382: error: invalid operands to binary &
demux_ogg.c:383: warning: assignment from incompatible pointer type
demux_ogg.c:388: error: invalid operands to binary &
demux_ogg.c:395: error: invalid operands to binary |
demux_ogg.c: In function `demux_ogg_add_packet':
demux_ogg.c:498: error: invalid operands to binary &
demux_ogg.c:523: error: invalid operands to binary -
demux_ogg.c:524: error: invalid operands to binary -
demux_ogg.c: In function `demux_ogg_scan_stream':
demux_ogg.c:583: warning: initialization makes pointer from integer without a cast
demux_ogg.c:638: warning: initialization makes pointer from integer without a cast
demux_ogg.c: In function `demux_ogg_open':
demux_ogg.c:697: warning: assignment makes pointer from integer without a cast
demux_ogg.c:736: warning: passing arg 1 of `strlen' from incompatible pointer type
demux_ogg.c:736: warning: passing arg 1 of `strlen' from incompatible pointer type
demux_ogg.c:736: warning: passing arg 1 of `strlen' from incompatible pointer type
demux_ogg.c:736: warning: passing arg 1 of `strcmp' from incompatible pointer type
demux_ogg.c:736: warning: passing arg 1 of `strncmp' from incompatible pointer type
demux_ogg.c:745: warning: passing arg 1 of `strlen' from incompatible pointer type
demux_ogg.c:745: warning: passing arg 1 of `strlen' from incompatible pointer type
demux_ogg.c:745: warning: passing arg 1 of `strlen' from incompatible pointer type
demux_ogg.c:745: warning: passing arg 1 of `strcmp' from incompatible pointer type
demux_ogg.c:745: warning: passing arg 1 of `strncmp' from incompatible pointer type
demux_ogg.c:801: warning: passing arg 1 of `strlen' from incompatible pointer type
demux_ogg.c:801: warning: passing arg 1 of `strlen' from incompatible pointer type
demux_ogg.c:801: warning: passing arg 1 of `strlen' from incompatible pointer type
demux_ogg.c:801: warning: passing arg 1 of `strcmp' from incompatible pointer type
demux_ogg.c:801: warning: passing arg 1 of `strncmp' from incompatible pointer type
demux_ogg.c:809: error: aggregate value used where an integer was expected
demux_ogg.c:809: error: aggregate value used where an integer was expected
demux_ogg.c:809: error: aggregate value used where an integer was expected
demux_ogg.c:809: error: aggregate value used where an integer was expected
demux_ogg.c:849: error: invalid operands to binary &
demux_ogg.c: In function `demux_ogg_fill_buffer':
demux_ogg.c:1036: warning: assignment makes pointer from integer without a cast
demux_ogg.c: In function `init_avi_with_ogg':
demux_ogg.c:1126: warning: assignment makes pointer from integer without a cast
demux_ogg.c: In function `demux_ogg_seek':
demux_ogg.c:1281: warning: initialization makes pointer from integer without a cast
make[1]: * [demux_ogg.o] Error 1
make[1]: Leaving directory `/tmp/MPlayer-1.0pre5/libmpdemux'
make:
* [libmpdemux/libmpdemux.a] Error 2

Change History (7)

comment:1 Changed 15 years ago by reimar

(In reply to comment #0)

gcc -c -I../libvo -I../../libvo -I/usr/X11/include -s -O3 -march=i686

These are non-standard flags, when you use them you're on your own.
How did you configure? Could it be that you did --enable-vorbis? This will
disable autodetection and can easily break things unless you really know hwt
you're doing...

comment:2 Changed 15 years ago by pierre42d@…

No I didn't use --enable-vorbis, but I used --enable-tremor, is it related ?

comment:3 Changed 15 years ago by reimar

(In reply to comment #2)

No I didn't use --enable-vorbis, but I used --enable-tremor, is it related ?

That amounts to about the same. Don't use --enable, instead make sure that you
installed the library and headers correctly!

comment:4 Changed 15 years ago by pierre42d@…

In fact I have vorbis installed but not tremor.
But the configure should detect this and stop, it will avoid this compilation
error...

comment:5 Changed 15 years ago by reimar

Sorry, but unlike some other configure scripts ours doesn't think to know better
than the user. If you tell it to enable something it will enable it.
Because worse than stupid software is stupid software that thinks it is intelligent.

comment:6 Changed 15 years ago by dominik@…

Why is it still marked as NEW? I think it should be closed as INVALID. "It's a
feature, not a bug." :)

comment:7 Changed 15 years ago by moritz@…

  • Resolution set to invalid
  • Status changed from new to closed

Good point.

Note: See TracTickets for help on using tickets.