Opened 11 years ago

Closed 11 years ago

#1040 closed defect (invalid)

build fail on 10.5 with system iconv.h

Reported by: aborigeno79@… Owned by: diego@…
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Building from svn on Mac OS X 10.5 will fail with an error regarding iconv:
Undefined symbols:

"_iconv_close", referenced from:

_mp_msg in mp_msg.o
_subcp_close in subreader.o
_sub_read_file in subreader.o
_sub_read_file in subreader.o
_sub_read_file in subreader.o
_prepare_charset in libosd.a(font_load_ft.o)
_prepare_charset in libosd.a(font_load_ft.o)

"_iconv", referenced from:

_filename_recode in mp_msg.o
_mp_msg in mp_msg.o
_subcp_recode in subreader.o
_prepare_charset in libosd.a(font_load_ft.o)

"_iconv_open", referenced from:

_filename_recode in mp_msg.o
_mp_msg in mp_msg.o
_subcp_open in subreader.o
_sub_read_file in subreader.o
_prepare_charset in libosd.a(font_load_ft.o)
_prepare_charset in libosd.a(font_load_ft.o)

ld: symbol(s) not found
collect2: ld returned 1 exit status
make: * [mplayer] Error 1

this is due to an incompatibility with system supplied iconv.h under /usr/include
I successfully build mplayer overwriting /usr/include/iconv.h with the version coming with fink (or MacPorts? will be the same) from /sw/include/iconv.h

I suggest to made available a configure option --with-iconv which can be used to supply an alternate path for iconv package.

Change History (1)

comment:1 Changed 11 years ago by diego@…

  • Resolution set to invalid
  • Status changed from new to closed

There is --with-extraincdir and --with-extralibdir for this.

Note: See TracTickets for help on using tickets.