Opened 12 years ago

Closed 9 years ago

Last modified 9 years ago

#1056 closed defect (fixed)

ogg with large, multi-packet header does not work

Reported by: hendrik@… Owned by: reimar
Priority: normal Component: demuxer
Version: 1.0rc2 Severity: normal
Keywords: Cc: jason52lh@…, lucidlytwisted@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:


When playing an ogg file with big embedded cover art (in the COVERART tag) it crashes.

I tried a few coversizes with easytag: 30kB still worked, but 70kB didn't.

I didn't know the component, so I guessed one.

Change History (10)

comment:1 Changed 12 years ago by compn

  • Component changed from ad to demuxer

if you could provide a sample or way of creating such file
so we can reproduce the problem...

comment:2 Changed 12 years ago by hendrik@…

An example file can be downloaded from:

comment:3 Changed 12 years ago by reimar

  • Summary changed from Crash when playing Oggfile with big embedded cover to ogg with large, multi-packet header does not work

The crash is analyzed and (I expect) will be fixed soon, but that is not enough to make the file actually play.
I adjusted the summary a bit.

comment:4 Changed 10 years ago by jason52lh@…

  • Cc jason52lh@… added

Seems this related to METADATA_BLOCK_PICTURE filed in ogg tags.

See more:

VLC has the same problem:

"VLC and mplayer are the only programs/libraries I've found that won't play these files. Xine, gstreamer, ffmpeg, ogg123 and the Xiph DirectShow? filters will all play them without a problem."

i also found if ogg embedded cover art larger than 40kb, mplayer won't play, meanwhile other player works well.

i tired mplayer svn 32492 and git version, all have the same problem.

comment:5 Changed 10 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:6 Changed 10 years ago by reimar

Partially an FFmpeg issue: it both extracts the cover art as metadata and exports it in extradata, overflowing the 64 kB limit of extradata in wav/AVI/..., which unfortunately MPlayer currently shares.
Possible fix on ffmpeg-devel list.

comment:7 Changed 9 years ago by lucidlytwisted@…

  • Cc lucidlytwisted@… added

Is there any movement on this bug? I note that it's still an issue with MPlayer 1.0rc4-4.4.5.

comment:8 Changed 9 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

The fix has been applied to FFmpeg on the 31st of January and it works just fine with latest SVN MPlayer + FFmpeg.
rc4 is much, much older than the fix.

comment:9 Changed 9 years ago by lucidlytwisted@…

Thanks - guess the fix hasn't landed in my distro yet (Ubuntu). I'll see what I can do about updating my system.

comment:10 Changed 9 years ago by lucidlytwisted@…

I installed the MOTU Daily PPA and that fixed the issue.
Thanks very much!

Note: See TracTickets for help on using tickets.