Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#1087 closed defect (worksforme)

Mplayer plays multichannel flac files with non-standard channel order

Reported by: seivadmas@… Owned by: reimar
Priority: important Component: ao
Version: 1.0rc2 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Mplayer plays multichannel flac files as if they had channel order like: FL,FR,RL,RR,CEN,LFE.

The flac spec says that 5.1 flac should be encoded FL,FR,CEN,LFE,RL,RR.

This channel mismapping results in messed up surround sound for standards-compliant multichannel flacs. Here is a flac with "correct" channel mapping that can be used to confirm: http://137.222.225.69:8008/Multichannel_test_flac_standard_6.flac

Change History (4)

comment:1 Changed 9 years ago by russianneuromancer@…

  • Priority changed from normal to important

comment:2 Changed 9 years ago by zveroy@…

Years pass but bug still alive. Now many video files contain audio tracks in multichannel flacs. This bug makes big trouble of watching that video. Sorry for my english.

comment:3 Changed 9 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

These files play with the same order for me, and at least with -ao alsa that is the correct order:
http://samples.mplayerhq.hu/multichannel/6_Channel_ID.wav
http://samples.mplayerhq.hu/multichannel/6_Channel_ID.flac
Please make sure to test with latest SVN (though this should be fixed since many, many months already) and provide more details if the issue persists for you.

comment:4 Changed 9 years ago by zveroy@…

Sorry, it's my mistake. Problem not in channel order. ffflac not downmix channels and one can hear only first two on my 2.0 audio system.

Note: See TracTickets for help on using tickets.