Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#114 closed defect (fixed)

MPlayer doesn't compile under FreeBSD 5.3-BETA7

Reported by: aquatique@… Owned by: alex@…
Priority: normal Component: ao
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

gmake[1]: Entering directory `/big2/temp/MPlayer-20041018/libao2'
cc -c -I../libvo -I../../libvo -I/usr/X11R6/include -fno-PIC -O4 -march=pentium4
-mtune=pentium4 -pipe -ffast-math -fomit-frame-pointer -D_THREAD_SAFE
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/local/include -I. -I..
-I/usr/local/include -I/usr/X11R6/include -I/usr/local/include -o afmt.o afmt.c
afmt.c: In function `audio_out_format_name':
afmt.c:41: error: duplicate case value
afmt.c:39: error: previously used here
afmt.c:43: error: duplicate case value
afmt.c:33: error: previously used here
afmt.c:47: error: duplicate case value
afmt.c:37: error: previously used here
afmt.c: In function `audio_out_format_bits':
afmt.c:73: error: duplicate case value
afmt.c:65: error: previously used here
afmt.c:74: error: duplicate case value
afmt.c:66: error: previously used here
afmt.c:75: error: duplicate case value
afmt.c:67: error: previously used here
gmake[1]: * [afmt.o] Ошибка 1
gmake[1]: Leaving directory `/big2/temp/MPlayer-20041018/libao2'
gmake:
* [libao2/libao2.a] Ошибка 2

Attachments (3)

libao2.afmt.h2.patch (910 bytes) - added by aquatique@… 14 years ago.
Quick and dirty hack just in order to compile :)
afmt_compile.diff (586 bytes) - added by reimar 14 years ago.
another variant
afmt_compile.2.diff (586 bytes) - added by reimar 14 years ago.
fixed a typo.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 14 years ago by aquatique@…

this caused by conflicts with AFMT definitions in /usr/include/sys/soundcard.h:

aquatique@… <~> $ grep 'define AFMT_' /usr/include/sys/soundcard.h
#define AFMT_QUERY 0x00000000 /* Return current format */
#define AFMT_MU_LAW 0x00000001 /* Logarithmic mu-law */
#define AFMT_A_LAW 0x00000002 /* Logarithmic A-law */
#define AFMT_IMA_ADPCM 0x00000004 /* A 4:1 compressed format where 16-bit
#define AFMT_U8 0x00000008 /* Unsigned 8-bit */
#define AFMT_S16_LE 0x00000010 /* Little endian signed 16-bit */
#define AFMT_S16_BE 0x00000020 /* Big endian signed 16-bit */
#define AFMT_S8 0x00000040 /* Signed 8-bit */
#define AFMT_U16_LE 0x00000080 /* Little endian unsigned 16-bit */
#define AFMT_U16_BE 0x00000100 /* Big endian unsigned 16-bit */
#define AFMT_MPEG 0x00000200 /* MPEG MP2/MP3 audio */
#define AFMT_AC3 0x00000400 /* Dolby Digital AC3 */
#define AFMT_S16_NE AFMT_S16_LE /* native endian signed 16 */
#define AFMT_S16_NE AFMT_S16_BE
#define AFMT_S32_LE 0x00001000 /* Little endian signed 32-bit */
#define AFMT_S32_BE 0x00002000 /* Big endian signed 32-bit */
#define AFMT_U32_LE 0x00004000 /* Little endian unsigned 32-bit */
#define AFMT_U32_BE 0x00008000 /* Big endian unsigned 32-bit */
#define AFMT_STEREO 0x10000000 /* can do/want stereo */
#define AFMT_WEIRD 0x20000000 /* weird hardware... */
#define AFMT_FULLDUPLEX 0x80000000 /* can do full duplex */

aquatique@… <~> $ uname -a
FreeBSD aquatique.rsb.local 5.3-BETA7 FreeBSD 5.3-BETA7 #0: Wed Oct 6 13:10:56
OMSST 2004 root@…:/usr/obj/usr/src/sys/AQUATIQUE i386

Changed 14 years ago by aquatique@…

Quick and dirty hack just in order to compile :)

comment:2 Changed 14 years ago by aquatique@…

Changed 14 years ago by reimar

another variant

comment:3 Changed 14 years ago by reimar

Please try if this one works as well...

comment:4 Changed 14 years ago by aquatique@…

(In reply to comment #3)

another variant
Please try if this one works as well...

gmake[1]: Entering directory `/big2/temp/MPlayer-20041020/libao2'
cc -c -I../libvo -I../../libvo -I/usr/X11R6/include -fno-PIC -O4 -march=pentium4
-mtune=pentium4 -pipe -ffast-math -fomit-frame-pointer -D_THREAD_SAFE
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/local/include -I. -I..
-I/usr/local/include -I/usr/X11R6/include -I/usr/local/include -o afmt.o afmt.c
afmt.c: In function `audio_out_format_name':
afmt.c:41: error: duplicate case value
afmt.c:39: error: previously used here
afmt.c:43: error: duplicate case value
afmt.c:33: error: previously used here
afmt.c:47: error: duplicate case value
afmt.c:37: error: previously used here
afmt.c: In function `audio_out_format_bits':
afmt.c:73: error: duplicate case value
afmt.c:65: error: previously used here
afmt.c:74: error: duplicate case value
afmt.c:66: error: previously used here
afmt.c:75: error: duplicate case value
afmt.c:67: error: previously used here
gmake[1]: * [afmt.o] Ошибка 1
gmake[1]: Leaving directory `/big2/temp/MPlayer-20041020/libao2'
gmake:
* [libao2/libao2.a] Ошибка 2

:-D

Changed 14 years ago by reimar

fixed a typo.

comment:5 Changed 14 years ago by reimar

comment:6 Changed 14 years ago by reimar

  • attachments.isobsolete changed from 0 to 1

comment:7 Changed 14 years ago by aquatique@…

  • Resolution set to fixed
  • Status changed from new to closed

yo, this patch runs fine

comment:8 Changed 14 years ago by reimar

In CVS now.
btw.: please don't set to resolved, as this currently is supposed to mean "fixed
in CVS"

Note: See TracTickets for help on using tickets.