Opened 15 years ago

Closed 13 years ago

Last modified 13 years ago

#118 closed defect (fixed)

fullscreen doesn't work anymore [kdm]

Reported by: hpj@… Owned by: beastd
Priority: normal Component: vo
Version: HEAD Severity: major
Keywords: Cc: hpj@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Since 1.0pre5, and with current cvs, FS doesn't work anymore:
It resizes the image, but not the window itself, which is rather ineffectual.

I've tried several -vo targets, xv, mga, xmga, where xmga is selected by
default. Also varying -fstype arguments doesn't change the picture..

You will find the output of the command
mplayer -v -fs -pp 0x20000 vts_01_1.vob
attached.

System:
SuSE 9.0, KDE 3.14, Kernel 2.4.21-243-athlon
Athlon XP 2600+, MGA 450, 19' TFT

Attachments (1)

mplayer.log (15.0 KB) - added by hpj@… 15 years ago.
output of: mplayer -v -fs -pp 0x20000 vts_01_1.vob

Download all attachments as: .zip

Change History (6)

Changed 15 years ago by hpj@…

output of: mplayer -v -fs -pp 0x20000 vts_01_1.vob

comment:1 Changed 15 years ago by hpj@…

comment:2 Changed 14 years ago by hpj@…

Just checked the current CVS, and problem retains.

MPlayer dev-CVS-041218-20:50-3.3.1 (C) 2000-2004 MPlayer Team
CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping:
10)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Kompiliert für x86 CPU mit folgenden Erweiterungen: MMX MMX2 3DNow 3DNowEx SSE

Anything wrong with this?

Here's the output of mplayer -v -fs some.mpg:

Starte Wiedergabe...
VDec: VO wird versucht, auf 448 x 336 (Bevorzugter Farbraum: Planar YV12) zu
setzen.
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Film-Aspekt ist undefiniert - keine Vorskalierung durchgeführt.
VO Config (448x336->448x336,flags=1,'MPlayer',0x32315659)
VO: [xmga] 448x336 => 448x336 Planar YV12 [fs]
VO: Description: Matrox G200/G4x0/G550 overlay in X11 window (using /dev/
mga_vid)
VO: Author: Zoltan Ponekker <pontscho@…>
[mga] Using 3 buffers.
Using colorkey: 7e0
[xmga] x: 416 y: 344 w: 448 h: 336
[xmga] dcx: 416 dcy: 344 dx: 0 dy: 0 dw: 448 dh: 336
[xmga-fs] dcx: 416 dcy: 344 dx: 0 dy: 0 dw: 1280 dh: 1024
* [vo] Allocating mp_image_t, 448x336x12bpp YUV planar, 225792 bytes
* [vo] Allocating mp_image_t, 448x336x12bpp YUV planar, 225792 bytes
* [vo] Allocating mp_image_t, 448x336x12bpp YUV planar, 225792 bytes
[xmga] x: 0 y: 0 w: 448 h: 336ct: 0.051 14/ 14 30% 4% 2.9% 0 0
[xmga] dcx: 416 dcy: 344 dx: 0 dy: 0 dw: 448 dh: 336
[xmga-fs] dcx: 416 dcy: 344 dx: 0 dy: 0 dw: 1280 dh: 1024
[xmga] x: 0 y: 0 w: 448 h: 336ct: 0.055 15/ 15 29% 4% 2.7% 0 0
[xmga] dcx: 416 dcy: 344 dx: 0 dy: 0 dw: 448 dh: 336
[xmga-fs] dcx: 416 dcy: 344 dx: 0 dy: 0 dw: 1280 dh: 1024
Uninit audio filters... 0.003 ct: 0.070 107/107 7% 3% 1.6% 0 0
[libaf] Removing filter dummy
Deinitialisiere Audio: mp3lib
Deinitialisiere Video: libmpeg2
vo: uninit!
vo: uninit ...


comment:3 Changed 14 years ago by reimar

There are lots of problems currently because almost every window manager behaves
different. Using a different one often helps.
Sometimes some of the -fstype options help (-fstype help gives a list, -fstype
-fullscreen to disable fullscreen hint is often successful).
Hopefully it will be fixed for good soon, but I can't promise anything.

comment:4 Changed 13 years ago by diego@…

  • Owner changed from alex@… to beastd

comment:5 Changed 13 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Some things were changed, reopen if there are still problems that can't be
fixed with -fstype options.

Note: See TracTickets for help on using tickets.