Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#119 closed defect (fixed)

gmplayer can play mencoder created avi if it's bigger than 1G

Reported by: szo@… Owned by: alex@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I'm not sure if it's the same as bug #26, so I open a new bug. I'm ripping a dvd
with this command:
mencoder dvd://3 -alang fra -oac copy -vf
crop=700:550:10:14,hqdn3d=2:1:2,scale=350:275 -ovc lavc -lavcopts
vcodec=mpeg4:vbitrate=1000:v4mv:mbd=2:trell:cmp=3:subcmp=3:mbcmp=3:autoaspect:vpass=1
-o out.avi
more or less straight from the documentation. I can play the output avi while
encoding with gmplayer, up to the point when the encoding reaches the 1G size
and mencoder issues this message:
ODML: Starting new RIFF chunk at 1023MB.12min 1124mb A-V:0.043 [999:448]]
after this, when trying to play the file with gmplayer, it starts to eat the cpu
after this message:
"AVI file format detected." for several minutes, then starts spitting error
messages:
"Seek failed
AVI: No audio stream found -> no sound.
VIDEO: [DIVX] 350x275 24bpp 25.000 fps 900.7 kbps (109.9 kbyte/s)
Clip info:

Software: MEncoder 1.0pre5-3.3.4

==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 56000->192000 (448.0 kbit)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
==========================================================================
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
[mpeg4 @ 0x8569460]looks like this file was encoded with
(divx4/(old)xvid/opendivx) -> forcing low_delay flag
VDec: vo config request - 350 x 275 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.81:1 - prescaling to correct movie aspect.
VO: [xv] 350x275 => 498x275 Planar YV12
[mpeg4 @ 0x8569460]warning: first frame is no keyframe
[mpeg4 @ 0x8569460]2. marker bit missing in 3. esc
[mpeg4 @ 0x8569460]Error at MB: 14
[mpeg4 @ 0x8569460]concealing 2147483647 errors
Marker bit missing before vop_coded0.000 1/ 1 0% 0% 0.0% 0 0 0% 1.00x
[mpeg4 @ 0x8569460]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x8569460]header damaged
Error while decoding frame!
[mpeg4 @ 0x8569460]ac-tex damaged at 12 2 2/ 2 0% 0% 0.0% 0 0 0% 1.00x
[mpeg4 @ 0x8569460]Error at MB: 58
[mpeg4 @ 0x8569460]concealing 2147483647 errors
Marker bit missing before vop_coded0.008 3/ 3 0% 0% 0.0% 0 0 0% 1.00x
... and so on"

meanwhile, mplayer can play the file just fine.

Change History (1)

comment:1 Changed 13 years ago by diego@…

  • Component changed from core to demuxer
  • Resolution set to fixed
  • Status changed from new to closed

ODML problems should be fixed by now. Reopen the bug if you can reproduce the
problem with latest CVS.

Note: See TracTickets for help on using tickets.