Opened 11 years ago

Closed 11 years ago

#1192 closed defect (duplicate)

==27160== Invalid read of size 4

Reported by: jaypd@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc: catchconv-bugreports@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Can you please look into this invalid read?

debian:/home/user/valgrind/valgrind-3.3.1-stackhash# zzuf -vc -s 18 -r 0.0001:0.01 -x valgrind -q --error-exitcode=1 mplayer /home/user/foundBugs/mplayer/118-short0.mp30006.mp3
zzuf[s=18,r=0.0001:0.01]: launched `valgrind'
MPlayer dev-SVN-r27240-4.1.2 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz (Family: 6, Model: 15, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing /home/user/foundBugs/mplayer/118-short0.mp30006.mp3.
libavformat file format detected.
==27160== Invalid read of size 4
==27160== Stack hash: 139943826
==27160== at 0x8575F92: (within /usr/local/bin/mplayer)
==27160== Address 0x44068f6 is 422 bytes inside a block of size 424 alloc'd
==27160== Stack hash: 2554622906
==27160== at 0x401C882: memalign (vg_replace_malloc.c:460)
==27160== by 0x40278F0: memalign (lib-mem.c:209)
==27160==
==27160== Invalid read of size 4
==27160== Stack hash: 139938594
==27160== at 0x8574B22: (within /usr/local/bin/mplayer)
==27160== Address 0x44068f7 is 423 bytes inside a block of size 424 alloc'd
==27160== Stack hash: 2554622906
==27160== at 0x401C882: memalign (vg_replace_malloc.c:460)
==27160== by 0x40278F0: memalign (lib-mem.c:209)
[lavf] Audio stream found, -aid 0
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 384.0 kbit/27.21% (ratio: 48000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
mpg123: Can't rewind stream by 42 bits!
mpg123: Can't rewind stream by 131 bits!
mpg123: Can't rewind stream by 2042 bits!
mpg123: Can't rewind stream by 911 bits!
mpg123: Can't rewind stream by 69 bits!
mpg123: Can't rewind stream by 111 bits!
mpg123: Can't rewind stream by 11 bits!
mpg123: Can't rewind stream by 45 bits!
big_values too large!6 (02.6) ??,?%
mpg123: Can't rewind stream by 190 bits!
mpg123: Can't rewind stream by 50 bits!
mpg123: Can't rewind stream by 2 bits!
mpg123: Can't rewind stream by 8 bits!
mpg123: Can't rewind stream by 33 bits!
mpg123: Can't rewind stream by 34 bits!
mpg123: Can't rewind stream by 33 bits!
mpg123: Can't rewind stream by 1022 bits!
mpg123: Can't rewind stream by 25 bits!
A: 1.1 (01.1) of 2.6 (02.6) 49.5%

Exiting... (End of file)
zzuf[s=18,r=0.0001:0.01]: exit 1

Error can be reproduced by d/l'ing file from link above and running zzuf -vc -s 18 -r 0.0001:0.01 -x valgrind -q --error-exitcode=1 mplayer /home/user/foundBugs/mplayer/118-short0.mp30006.mp3 from the command line.

This bug was found using Zzuf as part of the 2008 SUPERB-TRUST metafuzz project (see http://www.truststc.org/superb/ and http://metafuzz.com/)

Change History (2)

comment:1 Changed 11 years ago by jaypd@…

  • bug_file_loc changed from http://www.cs.berkeley.edu/~jaypd/118-short0.mp30006.mp3 to http://www.cs.berkeley.edu/~jaypd/118-short0.mp30006.mp3

Ran again with debugging:

user@debian:~/songs$ zzuf -vc -s 18 -r 0.0001:0.01 -x valgrind -q --error-exitcode=1 mplayer 118-short0.mp30006.mp3
zzuf[s=18,r=0.0001:0.01]: launched `valgrind'
MPlayer dev-SVN-r27292-4.1.2 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz (Family: 6, Model: 15, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing 118-short0.mp30006.mp3.
libavformat file format detected.
==8672== Invalid read of size 4
==8672== Stack hash: 1315278785
==8672== at 0x8479839: mp_decode_frame (bitstream.h:619)
==8672== by 0x847AF2D: decode_frame (mpegaudiodec.c:2405)
==8672== by 0x82ECB9A: avcodec_decode_audio2 (utils.c:928)
==8672== by 0x8263B17: av_find_stream_info (utils.c:1828)
==8672== by 0x81A3035: demux_open_lavf (demux_lavf.c:466)
==8672== by 0x811E23A: demux_open_stream (demuxer.c:864)
==8672== by 0x811E501: demux_open (demuxer.c:991)
==8672== by 0x80779AE: main (mplayer.c:3238)
==8672== Address 0x43f9526 is 422 bytes inside a block of size 424 alloc'd
==8672== Stack hash: 4077560365
==8672== at 0x401C882: memalign (vg_replace_malloc.c:460)
==8672== by 0x40278F0: memalign (lib-mem.c:209)
==8672== by 0x825FFF4: av_dup_packet (utils.c:247)
==8672== by 0x8263371: av_find_stream_info (utils.c:2023)
==8672== by 0x81A3035: demux_open_lavf (demux_lavf.c:466)
==8672== by 0x811E23A: demux_open_stream (demuxer.c:864)
==8672== by 0x811E501: demux_open (demuxer.c:991)
==8672== by 0x80779AE: main (mplayer.c:3238)
==8672==
==8672== Invalid read of size 4
==8672== Stack hash: 3549864903
==8672== at 0x84796D7: mp_decode_frame (bitstream.h:619)
==8672== by 0x847AF2D: decode_frame (mpegaudiodec.c:2405)
==8672== by 0x82ECB9A: avcodec_decode_audio2 (utils.c:928)
==8672== by 0x8263B17: av_find_stream_info (utils.c:1828)
==8672== by 0x81A3035: demux_open_lavf (demux_lavf.c:466)
==8672== by 0x811E23A: demux_open_stream (demuxer.c:864)
==8672== by 0x811E501: demux_open (demuxer.c:991)
==8672== by 0x80779AE: main (mplayer.c:3238)
==8672== Address 0x43f9527 is 423 bytes inside a block of size 424 alloc'd
==8672== Stack hash: 4077560365
==8672== at 0x401C882: memalign (vg_replace_malloc.c:460)
==8672== by 0x40278F0: memalign (lib-mem.c:209)
==8672== by 0x825FFF4: av_dup_packet (utils.c:247)
==8672== by 0x8263371: av_find_stream_info (utils.c:2023)
==8672== by 0x81A3035: demux_open_lavf (demux_lavf.c:466)
==8672== by 0x811E23A: demux_open_stream (demuxer.c:864)
==8672== by 0x811E501: demux_open (demuxer.c:991)
==8672== by 0x80779AE: main (mplayer.c:3238)
[lavf] Audio stream found, -aid 0
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 384.0 kbit/27.21% (ratio: 48000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
mpg123: Can't rewind stream by 42 bits!
mpg123: Can't rewind stream by 131 bits!
mpg123: Can't rewind stream by 2042 bits!
mpg123: Can't rewind stream by 911 bits!
mpg123: Can't rewind stream by 69 bits!
mpg123: Can't rewind stream by 111 bits!
mpg123: Can't rewind stream by 11 bits!
mpg123: Can't rewind stream by 45 bits!
big_values too large!6 (02.6) ??,?%
mpg123: Can't rewind stream by 190 bits!
mpg123: Can't rewind stream by 50 bits!
mpg123: Can't rewind stream by 2 bits!
mpg123: Can't rewind stream by 8 bits!
mpg123: Can't rewind stream by 33 bits!
mpg123: Can't rewind stream by 34 bits!
mpg123: Can't rewind stream by 33 bits!
mpg123: Can't rewind stream by 1022 bits!
mpg123: Can't rewind stream by 25 bits!
A: 1.1 (01.1) of 2.6 (02.6) 48.5%

Exiting... (End of file)
zzuf[s=18,r=0.0001:0.01]: exit 1

comment:2 Changed 11 years ago by reimar

  • Resolution set to duplicate
  • Status changed from new to closed

* This bug has been marked as a duplicate of bug 1152 *

Note: See TracTickets for help on using tickets.