Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#121 closed defect (fixed)

Cannot use libdts?

Reported by: mardy@… Owned by: alex@…
Priority: normal Component: ao
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I've downloaded today mplayer from CVS; configured it with:

./configure --with-win32libdir=/usr/local/share/win32codecs/ --enable-libdts

$ mplayer -ac help |grep -i dts
ffdts ffmpeg working DTS [dts]
hwdts hwac3 working DTS through SPDIF

But if I use "mplayer -ac ffdts filename.avi", I get:
Requested audio codec family [ffdts] (afm=ffmpeg) not available.
Enable it at compilation.
Cannot find codec for audio format 0x2001.

Why??

Change History (2)

comment:1 Changed 15 years ago by r_togni@…

Did you got also libavcodec? If not, that's the cause of your porblem (MPlayer
uses libdts via libavcodec).

Always use CVS libavcodec (and libavformat) if you're using CVS MPlayer.

See README files for details.

comment:2 Changed 15 years ago by mardy@…

  • Resolution set to fixed
  • Status changed from new to closed

(In reply to comment #1)

Did you got also libavcodec? If not, that's the cause of your porblem (MPlayer
uses libdts via libavcodec).

Shame on me, it's the first time I get mplayer for CVS and I didn't notice that.
I'm closing the bug report.

Ciao!

Note: See TracTickets for help on using tickets.