Opened 11 years ago

Closed 11 years ago

#1213 closed defect (worksforme)

Some .WAV files cannot be played

Reported by: jidanni@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc2 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Some .WAV files cannot be played in mplayer.

For instance, the attached .WAV file, produced on a common S1MP3
player, such as those described at http://wiki.s1mp3.org/ .

This .WAV file is a recording of me saying this is a .WAV file.

You might say that this particular .WAV file is not a perfect standard
.WAV file, however I feel that the mighty mplayer program should still
be able to play it, as it can play most anything else.

$ file REC002.WAV
REC002.WAV: RIFF (little-endian) data, WAVE audio, IMA ADPCM, mono 8000 Hz

In fact, not only does it not play it, but it produces an error
message, attached. But as I am also submitting the .WAV file, I'm sure
the mplayer team can pinpoint the problem without me needing to get
into any deeper swimming pool water of all these protocols which are
over my head.

Attachments (1)

REC002.WAV (60.0 KB) - added by jidanni@… 11 years ago.
A .WAV file that mplayer cannot deal with

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by jidanni@…

A .WAV file that mplayer cannot deal with

comment:1 Changed 11 years ago by jidanni@…

In fact, mplayer makes this error message:
$ mplayer REC002.WAV
mplayer: /usr/lib/libtheora.so.0: no version information available (required by mplayer)
MPlayer dev-SVN-r26940
CPU: Intel(R) Celeron(R) M processor 1.40GHz (Family: 6, Model: 13, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.

Playing REC002.WAV.
Audio file file format detected.
==========================================================================
Opening audio decoder: [imaadpcm] IMA ADPCM audio decoder
AUDIO: 8000 Hz, 1 ch, s16le, 32.2 kbit/25.19% (ratio: 4031->16000)
Selected audio codec: [imaadpcm] afm: imaadpcm (IMA ADPCM)
==========================================================================
AO: [alsa] 48000Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...

MPlayer interrupted by signal 11 in module: decode_audio

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

comment:2 Changed 11 years ago by jidanni@…

VLC plays it just fine.

comment:3 Changed 11 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

It works for me, and ADPCM-support was completely overhauled recently.
So try a newer MPlayer version.

Note: See TracTickets for help on using tickets.