Opened 11 years ago

Closed 11 years ago

#1224 closed defect (duplicate)

SSA subtitles in .mkv files are not displayed properly

Reported by: lr13@… Owned by: eugeni.stepanov@…
Priority: normal Component: libass
Version: 1.0rc2 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

In some .mkv files MPlayer (v. 1.0rc2 r24722, Linux) shows not only the subtitle's text but some special symbols smth like this:

0 | 948 0 958 10 958 49
69 10 59 0 49 0 10 10 0

This strings appears over the speech text.

I enable SSA/ASS support but it didn't help.

I check this files in Windows (MediaPlayer? Classic from K-Lite Codec Pack 4.0) - all subs were displayed properly without any garbage.

I've found that this bug apears only when subs contain some pseudographics (frames, backgrounds etc.).

Maybe the cause is the new SSA specification?

PS: it's my first bug report so sorry if it's not good

Attachments (1)

sample-subtitles.ssa (35.4 KB) - added by lr13@… 11 years ago.
It's the sample of "bad" ssa subs: the garbage apears on the lines 69,70 and 78,79

Download all attachments as: .zip

Change History (4)

comment:1 Changed 11 years ago by compn

please upload the subtitle file if possible.
or small video sample with the problem.

Changed 11 years ago by lr13@…

It's the sample of "bad" ssa subs: the garbage apears on the lines 69,70 and 78,79

comment:2 Changed 11 years ago by lr13@…

comment:3 Changed 11 years ago by eugeni.stepanov@…

  • Resolution set to duplicate
  • Status changed from new to closed

Those are drawing commands, since r27442 they are ignored.

* This bug has been marked as a duplicate of bug 1227 *

Note: See TracTickets for help on using tickets.