Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1227 closed defect (fixed)

incomplete support of SSA:Drawings | неполная поддержка SSA:Рисование

Reported by: m1el@… Owned by: eugeni.stepanov@…
Priority: normal Component: libass
Version: 1.0rc2 Severity: normal
Keywords: Cc: lr13@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

looks like libass don't support drawings in ssa/ass files.
not really a bug and drawings is not so important in subtitles, but some subtitles contain drawing. watching string like "m 5 0 s 95 0 100 5 100 95 95 100 5 100 0 95 0 5 c" instead of drawing is really bad for me (or someone else).
why "incomplete support"? because in the file titled "Sub Station Alpha v4.00+ Script Format" you can read about override code "\p".


похоже, что libass не поддерживает рисование в файлах ssa/ass.
не совсем глюк, да и рисование в субтатрах не так важно, но видеть строчку типа "m 5 0 s 95 0 100 5 100 95 95 100 5 100 0 95 0 5 c" вместо рисовки не очень притно.
я считаю, что это неполная поддержка потому что в доках описание рисования есть и в других плеерах рисование поддерживается.

Change History (2)

comment:1 Changed 11 years ago by eugeni.stepanov@…

  • Resolution set to fixed
  • Status changed from new to closed

Since r27442 drawing commands are ignored without printing garbage on screen.

comment:2 Changed 11 years ago by eugeni.stepanov@…

  • Cc lr13@… added

* Bug 1224 has been marked as a duplicate of this bug. *

Note: See TracTickets for help on using tickets.