Opened 11 years ago

Last modified 9 years ago

#1229 closed defect (worksforme)

qtaudio playing back QCELP audio corrupt

Reported by: rectalogic@… Owned by: r_togni@…
Priority: normal Component: ad
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Some videos with QCELP audio play back OK, but this one plays OK in QuickTime? Player but in mplayer the audio is very choppy and unidentifiable. I'm uploading the sample video to upload.mplayerhq.hu/MPlayer/incoming/qtaudio-qcelp-problem.3g2

Attachments (1)

mplayer-qtaudio.log (27.0 KB) - added by rectalogic@… 11 years ago.
mplayer -v output

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by rectalogic@…

mplayer -v output

comment:1 Changed 11 years ago by rectalogic@…

comment:2 Changed 11 years ago by compn

reproduced, buggy audio with mplayer.
in quicktime it sounds like a guy laughing then 'thats going on myspace'.

comment:3 Changed 11 years ago by compn

moved to samples/A-codecs/qclp/qtaudio-qcelp-problem.3gp

comment:4 Changed 10 years ago by rectalogic@…

mplayer r29352 plays the sound correctly when using "-ac ffqclp"

I also have a second sample file that has the same issue, qtaudio qclp plays it distorted, ffqclp plays it correctly.

Is it time to mark ffqclp as "working" in codecs.conf or are there still known issues with it?

comment:5 Changed 9 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed, patriotact@gmail.com

still broken with qtaudio but now ffqclp is default so mark this as works4me since we will probably never know whats wrong with the binary decoder.

Note: See TracTickets for help on using tickets.