Opened 11 years ago

Closed 11 years ago

#1252 closed defect (fixed)

mplayer hangs on mp4 files from google video

Reported by: hanno@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc: mail@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Recently, all mp4-download videos from google video (the ipod/psp ones) just hang mplayer.

hanno@laverne ~/Desktop $ mplayer 3d3a20c3ba277579.avi.mp4
MPlayer dev-SVN-r27458-4.3.1 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Pentium(R) M processor 1300MHz (Family: 6, Model: 9, Stepping: 5)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Kompiliert für x86 CPU mit folgenden Erweiterungen: MMX MMX2 SSE SSE2

Spiele 3d3a20c3ba277579.avi.mp4.
libavformat-Dateiformat erkannt!

Then nothing happens any more.

(I'm obviously not 100% sure if it happens on all google videos, but all I tried, so here's a link where I've tried:

http://video.google.com/videoplay?docid=5393904704265757054&hl=de
)

mplayer is current svn built with just --disable-mencoder --disable-gui and no other special flags.

Change History (5)

comment:1 Changed 11 years ago by compn

mplayer -demuxer mov should work

comment:2 Changed 11 years ago by mail@…

  • Cc mail@… added

I noticed the same behaviour with files from tagesschau.de (can provide samples..). -demuxer mov works with these files.

(I'm using mplayer svn revision 27573.)

comment:3 Changed 11 years ago by compn

yes, small samples would be nice
can you also try them with ffplay?
if they freeze ffplay/ffmpeg then report to ffmpeg roundup tracker

comment:4 Changed 11 years ago by compn

mp4 freeze bug was recently fixed in svn, please update and retry.

comment:5 Changed 11 years ago by mail@…

  • Resolution set to fixed
  • Status changed from new to closed

It was only mplayer which was hanging on the files.
But yes, the bug disappeared after trying with a recent updated mplayer.

I also downloaded the google video file in question, no problem there either. As I see it, the issue is solved.

Note: See TracTickets for help on using tickets.