Opened 11 years ago

Last modified 9 years ago

#1255 closed defect (fixed)

When decoding AVCHD, mplayer and mencoder do not recover from a decoding glitch.

Reported by: djtm@… Owned by: r_togni@…
Priority: normal Component: vd
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

mplayer-dev-SVN-r27477-4.2.3

I play an m2ts file:
mplayer -fps 50 -vf pp=fd 00001.m2ts

mplayer play the file just fine at first. But then it creates gradully more block noise reproducibly at one point until the picture is completely distorted and blueish and from then on it seems like that scene only gets repeated.

It looks like it's getting stuck with one keyframe and keeps trying to use the new motion sectors all on that key frame only. This distorts the keyframe more and more. Then after about a second the picture is reset to that same keyframe, which is shown for one frame, then immediately back to the distorted picture.

The console tells me
[h264 @ 0xc1b7a0]Missing reference picture
[h264 @ 0xc1b7a0]illegal short term buffer state detected
see http://paste.ubuntu.com/40130/ for more of the same. And http://paste.ubuntu.com/40134/ for a complete log from start to the point where the problem starts.

The problem occurs also with mencoder when transcoding.
The problem does not happen when transcoding with ffmpeg HEAD. (It does not play at all with ffplay, because it doesn't find the frames per second. But it encodes fine. Maybe it skips a frame...)

The problem occurs at some point with most m2ts files.

Please let me know what other information you might need.

Attachments (1)

mplayer2.log (21.4 KB) - added by djtm@… 11 years ago.
stderr output

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by djtm@…

stderr output

comment:1 Changed 11 years ago by djtm@…

comment:2 Changed 11 years ago by djtm@…

  • Summary changed from When transcoding directly from AVCHD, mencoder does not recover from a decoding glitch. to When decoding AVCHD, mplayer and mencoder do not recover from a decoding glitch.

comment:3 Changed 9 years ago by compn

  • Resolution set to invalid
  • Status changed from new to closed, patriotact@gmail.com

probably fixed in svn, if you have a sample that shows the problem, please upload it.

comment:4 Changed 9 years ago by djtm@…

  • Resolution changed from invalid to fixed

indeed.

Note: See TracTickets for help on using tickets.