Opened 11 years ago

Last modified 8 years ago

#1290 closed defect (fixed)

The problem with multimedia keys PlayPause in the GUI.

Reported by: unihorn@… Owned by: reimar
Priority: normal Component: GUI
Version: unspecified Severity: normal
Keywords: Cc: ib
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Sorry for the bad language. I use a program interpreter (below the text in Russian).

The problem with multimedia keys PlayPause? in the GUI.

When you press PlayPause?, it is similar to the key Enter (starts playing a file). And any way you can not compel her to work as expected (does not make it to activate the regime pause) ...

In trying to understand what's wrong, I put comments in input.c against everything that relates to the keys, and I completely remove a file input.conf.

But Enter, and it seems working, key PlayPause?, stayed, while functional ...

Comments have been set against MP_CMD_GUI_PLAY (in input.c, and input.h).

Output remained unchanged.

That is to say. I was unable to identify the cause of this behavior PlayPause?. I can say only that the reason for not input.c.

Please fix. I am not so experience in this regard :(.

Best regards.

===========

RUS:

Простите за плохое знание языка. Я использую программу переводчик (внизу текст на русском языке).

Проблема с мультимедийной клавишей PlayPause? в GUI.

При нажатии клавиши PlayPause?, она действует аналогично клавише Enter (начинает воспроизведение следующего файла). И никаким образом не удается ее заставить работать как надо (не получается заставить активировать ею режим пауза)...

Пытаясь понять в чем дело, я поставил коментарии в input.c против всего, что касается клавиш, и я полностью удалил файл input.conf.

Но Enter, и, похоже работающая, клавиша PlayPause?, оставались, при этом, работоспособными...

Коментарии были поставленны и против MP_CMD_GUI_PLAY (в input.c и input.h).

Результат остался неизменен.

То есть., мне не удалось выявить причину такого поведения PlayPause?. Могу сказать только то, что причина не в input.c.

Пожалуйста исправьте. Я не настолько опытен в этом вопросе :(.

Change History (5)

comment:1 Changed 11 years ago by compn

to workaround this, you can put input.conf back
and change
ENTER pt_step 1 1
to
ENTER pause

it looks like your PlayPause? button is sending the ENTER key to mplayer
i am not sure why.

comment:2 Changed 11 years ago by unihorn@…

Sorry for the delay (I have not much time :().

Unfortunately, you have proposed does not solve the problem.

Personally, I have the feeling that in the code, there are other places where the processing of these keys (with a higher priority than input.c)

===================================

Простите за задержку (у меня не так много времени :().

К сожелению, предложенное вами, не решает проблему.

Лично у меня возникло ощущение, что в коде есть другие места где проводится обработка этих клавиш (имеющая приоритет выше чем в input.c)

comment:3 Changed 11 years ago by compn

is Xorg grabbing your multimedia keys?

mplayer would say No bind found for key i think.

comment:4 Changed 11 years ago by unihorn@…

X system (according to utility xev) sees MM keys (if I understood the question ...).

Xorg.conf file standard.

=============================

X система (если верить утилите xev) видит ММ клавиши (если я правильно понял вопрос...).

Файл xorg.conf стандартный.

comment:5 Changed 8 years ago by ib

  • Resolution set to fixed
  • Status changed from new to closed, ib@wupperonline.de

fixed in svn r33613

Note: See TracTickets for help on using tickets.