Opened 11 years ago

Closed 11 years ago

#1293 closed defect (fixed)

mencoder 1.0rc2 segfaulting (with backtrace)

Reported by: fragabr@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: 1.0rc2 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Linux 2.6.26
gcc 4.3.2

The 1.0rc2 version gives me the following:

fraga@tux ~/src$ gdb mencoder
GNU gdb 6.6
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu"...
Using host libthread_db library "/lib64/libthread_db.so.1".
(gdb) run -tv device=/dev/video1:input=3:norm=pal-m:amode=1:contrast=5:saturation=-10:brightness=5 -ovc xvid -xvidencopts pass=1 -oac mp3lame -o /home/fraga/src/tvrecord-${TODAY}-${NOW}.avi tv://
Starting program: /usr/local/bin/mencoder -tv device=/dev/video1:input=3:norm=pal-m:amode=1:contrast=5:saturation=-10:brightness=5 -ovc xvid -xvidencopts pass=1 -oac mp3lame -o /home/fraga/src/tvrecord-${TODAY}-${NOW}.avi tv://
[Thread debugging using libthread_db enabled]
[New process 28916]
MEncoder 1.0rc2-4.3.2 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 5600+ (Family: 15, Model: 67, Stepping: 3)
CPUflags: Type: 15 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

success: format: 9 data: 0x0 - 0x0
TV file format detected.
Selected driver: v4l2

name: Video 4 Linux 2 input
author: Martin Olschewski <olschewski@…>
comment: first try, more to come ;-)

Selected device: PowerColor? RA330

Tuner cap:
Tuner rxs:
Capabilites: video capture VBI capture device tuner read/write streaming
supported norms: 0 = NTSC-M; 1 = NTSC-M-JP; 2 = NTSC-443; 3 = PAL-BG; 4 = PAL-I; 5 = PAL-DK; 6 = PAL-M; 7 = PAL-N; 8 = PAL-Nc; 9 = PAL-60; 10 = SECAM-DK; 11 = SECAM-L;
inputs: 0 = for debug only; 1 = Television; 2 = Composite1; 3 = S-Video;
Current input: 3
Current format: BGR24

v4l2: current audio mode is : STEREO
v4l2: ioctl set format failed: Invalid argument
v4l2: ioctl set format failed: Invalid argument
v4l2: 0 frames successfully processed, 0 frames dropped.
[New Thread 139697577019120 (LWP 28916)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 139697577019120 (LWP 28916)]
uninit (priv=0x0) at tvi_v4l2.c:1062
1062 priv->vbi_shutdown=1;
(gdb) bt
#0 uninit (priv=0x0) at tvi_v4l2.c:1062
#1 0x000000000053912c in demux_close_tv (demuxer=0x234cdf0) at tv.c:775
#2 0x00000000004c98c2 in free_demuxer (demuxer=0x234cdf0) at demuxer.c:301
#3 0x00000000004c9e97 in demux_open_stream (stream=0x234c410, file_format=9, force=0, audio_id=-1, video_id=-1, dvdsub_id=-2, filename=0x22f36c0 "tv://") at demuxer.c:718
#4 0x00000000004c9ff3 in demux_open (vs=0x234c410, file_format=7, audio_id=4451120, video_id=-1, dvdsub_id=0, filename=0x22f36c0 "tv://") at demuxer.c:872
#5 0x000000000043b6e2 in main (argc=<value optimized out>, argv=<value
optimized out>) at mencoder.c:605

*

Any hints?

Change History (1)

comment:1 Changed 11 years ago by fragabr@…

  • Resolution set to fixed
  • Status changed from new to closed

The solution was to compile it with my own flags (-O2 -march=native)... I think the default mplayer flags cause this (maybe -O3, --fast-math or other, I don't know).

Ps: -O4 is useless since -O3 is the maximum value por optimization.

Note: See TracTickets for help on using tickets.