Opened 11 years ago

Closed 10 years ago

#1299 closed defect (fixed)

Audio drift with Canon Ixus 870 avc1 .mov

Reported by: skarkkai-mplayer@… Owned by: r_togni@…
Priority: normal Component: vd
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Canon's just released compact camera Ixus 870 creates quicktime files with avc1 fourcc. When mplayed with a recent mplayer (such as r27608 from 2009-09-13) audio plays much faster than video. Mplayer also shows following kind of messages about twice a second:

[h264 @ 0x88d52d0]AVC: Consumed only 39481 bytes instead of 394840 66%
[h264 @ 0x88d52d0]AVC: Consumed only 37697 bytes instead of 377000 64%

Ubuntu 7.04's mplayer rc2 doesn't have audio sync drift. It shows the same messages, and in addition these messages:

[h264 @ 0x8939870]AVC: nal size 0

There is a sample video in http://www.woods.iki.fi/t/ixus870-avc1.mov

Change History (5)

comment:1 Changed 11 years ago by skarkkai-mplayer@…

A little correction to the above: I meant to write that it's mplayer of Ubuntu 8.04, not 7.04, that plays the video without audio sync drift.

comment:2 Changed 11 years ago by compn

nice sample video.

reproduced with svn mplayer.

can you check with ffmpeg / ffplay , if the sync isnt correct, report to
ffmpeg roundup ?

comment:3 Changed 11 years ago by skarkkai-mplayer@…

Today's svn ffplay r15509 plays the video correctly, with audio in sync.

comment:4 Changed 11 years ago by skarkkai-mplayer@…

I might add that ffplay displays similar though not identical "Consumed only..." lines that mplayer does, despite having the audio in sync:

[h264 @ 0x882bd70]AVC: Consumed only 39481 bytes instead of 39484
[h264 @ 0x882bd70]AVC: Consumed only 37697 bytes instead of 37700

Etc.

comment:5 Changed 10 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in svn since -demuxer lavf is default now.
reopen if not.

Note: See TracTickets for help on using tickets.