Opened 11 years ago

Closed 11 years ago

#1301 closed defect (fixed)

tv grab broken since kernel update to 2.6.26

Reported by: fiddler0@… Owned by: r_togni@…
Priority: normal Component: vd
Version: HEAD Severity: normal
Keywords: Cc: fiddler0@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

With update to kernel 2.6.26.3 (fedora9) tv grabbing broke with mplayer/mencoder. Sound is fine, but image is unusable, looks like tuner is severely off. With a bt878 card I get this kernel msg:
kernel: bttv0: PLL can sleep, using XTAL (28636363)
I've tried the "pll=" bttv module option, but that only got rid of the kernel msg, not of the problem.

A saa7134 card gives no kernel msg, but the image is detuned as well, in a different way.
tvtime works well with both cards. If (and only if) I had tried mplayer with the bttv card right before I get this:
kernel: bttv0: PLL: 28636363 => 35468950 .. ok

Screenshots are here:
http://www.thefiddler.de/tmp/bttv.png
http://www.thefiddler.de/tmp/saa7134.png
Both times I had tuned in to the same station.

With the previous kernel (2.6.25.14-108.fc9.x86_64) all works well.

Change History (2)

comment:1 Changed 11 years ago by fiddler0@…

  • Cc fiddler0@… added

comment:2 Changed 11 years ago by fiddler0@…

  • Resolution set to fixed
  • Status changed from new to closed

(In reply to comment #0)
Apparently, with kernel 2.6.26 enumeration of normids had changed (from 0 to 5 for PAL-BG), and with "normid=0" in the conf file I was inadvertently attempting to grab a PAL signal in NTSC.
Resolved.

Note: See TracTickets for help on using tickets.