Opened 11 years ago

Closed 11 years ago

#1303 closed defect (duplicate)

WMV streaming does not work

Reported by: cusc16b02@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: 1.0rc2 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

MPlayer 1.0rc2-4.3.0 (Fedora packaged)
Fedora 9
All binary win32 codecs from mplayerhq.hu
mplayerplug-in 3.40-1.fc7
Firefox 3.0.2


Perhaps the embedded stream at the indicated example URL is malformed somehow, in which case I'd greatly appreciate to learn what to tell the publishers of the video so they can fix it.

When trying to play the embedded stream in Firefox with mplayerplug-in, the plug-in loads and I get the message "Connecting to server qstream-wm.qbrick.com", plus a continuously changing IP address. Nothing else happens.

I copied the direct URL of the stream using a right-click in the plugin space, and ran mplayer on that URL in a terminal:

$ mplayer http://qstream-wm.qbrick.com/05076/sveriges_afrikanska_krig_080911_s00_p00_webspecial.wmv?MSWMExt=.asf
MPlayer 1.0rc2-4.3.0 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(TM) XP (Family: 6, Model: 10, Stepping: 0)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing http://qstream-wm.qbrick.com/05076/sveriges_afrikanska_krig_080911_s00_p00_webspecial.wmv?MSWMExt=.asf.
Resolving qstream-wm.qbrick.com for AF_INET...
Connecting to server qstream-wm.qbrick.com[194.14.242.156]: 80...
Cache size set to 320 KBytes


The last four lines are then repeated rapidly end endlessly, with occasionally changing IP addresses. Nothing else happens. On Ctrl-C, it stops with the message "MPlayer interrupted by signal 2 in module: open_stream"

Change History (1)

comment:1 Changed 11 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed

user-agent=WMPlayer/10.0.0.4058
will fix your problem

duplicate of bug 1036

* This bug has been marked as a duplicate of bug 1036 *

Note: See TracTickets for help on using tickets.