Opened 11 years ago

Last modified 9 years ago

#1333 closed defect (duplicate)

subtitles disappear after seek command

Reported by: c_kruk@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: unspecified Severity: normal
Keywords: Cc: compn, fragabr@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I tested the current MPlayer subversion (dev-SVN-r27957-4.2.3) and I noticed following problem... Although I can cycle through subtitles using j key there is the problem with seek keys (PgUp?, PgDn?, and arrows). If I use some seek key to skip the stream in dvdnav:// mode mplayer forgets selected previously subtitles and I need cycle through all of them anew. In dvd:// mode there is no problem with seeking stream and displaying subtitles.

I installed in the system: libdvdcss-1.2.10, libdvdread-4.1.3, libdvdnav-4.1.3, libdca-0.0.5, and mplayer-codecs-all-20071007.

To configure MPlayer source I used the command: ./configure --disable-dvdread-internal --enable-gui --prefix=/opt/MPlayer.svn.

To run MPlayer I use the following commands:

mplayer -alang fr -slang fr -dvd-device /dev/dvd1 -dvd-speed 1 dvd://

mplayer -alang fr -slang fr -dvd-device /dev/dvd1 -dvd-speed 1 -mouse-movements dvdnav://

Described problem isn't new -- I noticed it also when I tried dev-SVN-r27865.

$ mplayer -alang fr -slang fr -dvd-device /dev/dvd1 -dvd-speed 1 -mouse-movements dvdnav://

MPlayer dev-SVN-r27957-4.2.3 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM) Duo CPU T2400 @ 1.83GHz (Family: 6, Model: 14, Stepping: 12)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing dvdnav://.
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdnav: DVD Title: SIMPSONS_SEASON4_D1
libdvdnav: DVD Serial Number: 30D15B96
libdvdnav: DVD Title (Alternative): SIMPSONS_SEASON4_D1
libdvdnav: Unable to find map file '/home/cezary/.dvdnav/SIMPSONS_SEASON4_D1.map'
libdvdnav: DVD disk reports itself with Region mask 0x00fd0000. Regions: 2

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000130
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00000241
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x000028d5
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x0004639e
libdvdread: Elapsed time 0
libdvdread: Found 2 VTS's
libdvdread: Elapsed time 0
libdvdnav: Language 'en' not found, using 'ÿÿ' instead
libdvdnav: Menu Languages available: ÿÿ
libdvdnav: Language 'en' not found, using 'ÿÿ' instead
libdvdnav: Menu Languages available: ÿÿ
libdvdnav: Language 'en' not found, using 'ÿÿ' instead
libdvdnav: Menu Languages available: ÿÿ
libdvdnav: Language 'en' not found, using 'ÿÿ' instead
libdvdnav: Menu Languages available: ÿÿ
libdvdnav: Language 'en' not found, using 'ÿÿ' instead
libdvdnav: Menu Languages available: ÿÿ
libdvdnav: Language 'en' not found, using 'ÿÿ' instead
libdvdnav: Menu Languages available: ÿÿ
Remember to disable MPlayer's cache when playing dvdnav:// streams (adding -nocache to your command line)
DVDNAV, switched to title: 2
MPEG-PS file format detected.
VIDEO: MPEG2 720x576 (aspect 2) 25.000 fps 5500.0 kbps (687.5 kbyte/s)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 768x576 Planar YV12
[mpeg2video @ 0x889c710]ac-tex damaged at 0 8
[mpeg2video @ 0x889c710]Warning MVs not available
[mpeg2video @ 0x889c710]concealing 1260 DC, 1260 AC, 1260 MV errors
a52: CRC check failed! 0.018 ct: 0.095 142/142 8% 0% 2.2% 0 0
a52: CRC check failed! 0.105 ct: 0.291 49/ 49 33% 0% 7.5% 0 0
a52: error at resampling
[mpeg2video @ 0x889c710]ac-tex damaged at 31 186 ??% ??% ??,?% 0 0
[mpeg2video @ 0x889c710]concealing 810 DC, 810 AC, 810 MV errors
DVDNAV, switched to title: 22 ct: 0.665 158/158 17% 0% 5.4% 0 0
a52: CRC check failed! 0.007 ct: 0.990 1934/1934 9% 0% 1.8% 0 0
a52: error at resampling
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
A: 803.2 V: 803.2 A-V: -0.004 ct: -0.005 702/702 8% 0% 1.3% 0 0
A: 812.1 V: 812.1 A-V: 0.009 ct: -0.003 926/926 8% 0% 1.3% 0 0
Exiting... (Quit)

Change History (5)

comment:1 Changed 10 years ago by fragabr@…

Any news on this? I have the exact same problem.

comment:2 Changed 10 years ago by eugeni.stepanov@…

  • Component changed from libass to demuxer
  • Owner changed from eugeni.stepanov@… to r_togni@…

It has nothing to do with libass, must be an issue with dvdnav streaming/demuxing.

comment:3 Changed 10 years ago by fragabr@…

  • Cc fragabr@… added

comment:4 Changed 10 years ago by fragabr@…

(In reply to comment #2)

It has nothing to do with libass, must be an issue with dvdnav
streaming/demuxing.

So, with whom I should ask this? I tried mplayer users and dvdnav author Rich Wareham, but without success.

comment:5 Changed 9 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed, patriotact@gmail.com

mark this bug dup of other bug, since other bug has patch at least.
did not verify if both bugs were fixed in svn tho...

Note: See TracTickets for help on using tickets.