Opened 11 years ago

Closed 7 years ago

#1355 closed defect (fixed)

Video Window Keeps Jumping.

Reported by: makitk@… Owned by: ib
Priority: normal Component: GUI
Version: unspecified Severity: trivial
Keywords: Cc: ib
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Ok, while I get Mplayer is /different/ in that the Video Window is seperate from the Video Controls Window, which can be great at some times, it is a rather annoying thing to constantly watch the Video Window jump to the exact center of the screen, even when moved to an alternate position.

This happens when moving from one video to another, as well as when booting up Mplayer with or without specifying a video to play upon boot.

Dealing with a lot of windows at any given time due to me being a busy person, this constantly forces me to move the window back in the corner I have put it in at the time.

I'm running Kubuntu 8.04 at the moment and Mplayer honestly isn't used that much by me, but Kaffeine decided to be annoying and not play the sound for the Matroska video files I was playing and Mplayer managed to do the job Kaffeine failed to.

The reason I've not been using MPlayer has been specified above. It would be nice if this got a fix as it's been this way for me since I started using Kubuntu, which was with the 6.10 release.
Throughout 6.10, 7.04 and now 8.04 this has been an issue but I never sent out a bugreport because, honestly? The MPlayer main site is confusing as all hell.

It took me about half an hour to get to SOME inclination that there was a support section and even then it was either signing up for some mailing list I don't give a damn about or reporting it on bugzilla. So here it is.

Now I do apologize for my language, but it's 5:35am and I've had it with work and programs that don't do what they're supposed to. (There's a "remember window position" option but it DOESN'T WORK!)

Change History (4)

comment:1 Changed 11 years ago by compn

hehe i think there was a fix for this
or it was fixed in svn , but now i cant remember

try a better frontend, like smplayer.

comment:2 Changed 11 years ago by reimar

You can use -geometry ot make the window appear at some specific place/size.
Nobody cared much about my previous patches to address this, so I did not bother.
Also there is a fundamental problem with "staying at the same position", the video window _size_ must change to avoid wrong aspect when playing a different file, and thus either the top left or bottom right position _must_ change.
Lastly, since you selected "GUI" as component: there is no futher development on the GUI, so the advise to try some other frontend like SMPlayer is a good one, because even if this is fixed for command-line MPlayer, it is unlikely to get fixed for the GUI.

comment:3 Changed 7 years ago by ib

  • Cc ib@… added
  • Owner changed from reimar to ib

comment:4 Changed 7 years ago by ib

  • Resolution set to fixed
  • Status changed from new to closed

fixed in svn r35757

Note: See TracTickets for help on using tickets.