Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1360 closed defect (wontfix)

Can't switch between audio tracks on the fly with OGM files

Reported by: rkrig@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: 1.0rc2 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

If I manually specify which audio track I want to play the video file with using "mplayer -aid 1", then I can select the other audio track.

However I can't switch between them on the fly. This is not a problem with MKV files for example. Just with OGM.

Since I like to control mplayer via IR remote control and in mythtv, its really annoying to have to manually specify the audio language, or re-mux the video file using ogmtools or avidemux.

Reproducible: Always

Tested on Gentoo AMD64
with Mplayer-1.0_rc2_p28058

Change History (2)

comment:1 Changed 11 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

Use -demuxer lavf for ogg files, then it should work.
Since the currently used "native" ogg demuxer will be replaced by the lavf one somewhen I don't expect that this feature will be implemented for it.
Note that one more "automatic" way to get this behaviour is to add "ogg" to the
"preferred_list" in libmpdemux/demux_lavf.c.

comment:2 Changed 11 years ago by rkrig@…

(In reply to comment #1)

Use -demuxer lavf for ogg files, then it should work.

Does that only work for ogg files, or can I put that into my ~/.mplayer/config file and have it work with all files?

Note: See TracTickets for help on using tickets.