Opened 11 years ago

Closed 11 years ago

#1362 closed defect (worksforme)

mplayer crashes when resizing window to null width

Reported by: porton@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc2 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I start mplayer with the following command:
$ mplayer -vo x11 -vf pp=lb -nocache /dev/video0

Then I resize window width so that it becomes zero (or near to zero).
mplayer crashes with
Segmentation faultA-V: 0.014 ct: -0.316 126/126 4% 8% 91.4% 65 0

Note that I use Sawfish window manager.

Change History (1)

comment:1 Changed 11 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

MPlayer sets the minimum width to 4x4, so your window manager should not allow you to set the size smaller than that.
In addition, while playback stops for me when the size is smaller that 2x2 with lots of X errors there is no crash (I tested with x11, xv and gl vos).
Since I can not reproduce the issue, someone needs to send a gdb backtrace from the crash, also it should be from latest SVN, maybe this issue was unintentionally fixed (rc2 is really, really old).

Note: See TracTickets for help on using tickets.