Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1367 closed defect (wontfix)

Powertop reports many wakeups when playing music

Reported by: luis6674@… Owned by: reimar
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I've noticed that mplayer causes many wakeups from idle (as reported by powertop) when playing music as compared to other players:

#mplayer myfile.mp3

Wakeups-from-idle per second : 255.4 interval: 5.0s
no ACPI power usage estimate available

Top causes for wakeups:

50.9% ( 97.4) mplayer : do_nanosleep (hrtimer_wakeup)
22.6% ( 43.2) <interrupt> : Intel 82801DB-ICH4
22.3% ( 42.6) konsole : schedule_timeout (process_timeout)

1.5% ( 2.8) plasma : schedule_timeout (process_timeout)
1.0% ( 2.0) <kernel core> : clocksource_register (clocksource_watchdog)
0.5% ( 1.0) klipper : schedule_timeout (process_timeout)

#mpg123 myfile.mp3

Wakeups-from-idle per second : 79.0 interval: 5.0s
no ACPI power usage estimate available

Top causes for wakeups:

82.7% ( 46.8) <interrupt> : Intel 82801DB-ICH4

5.3% ( 3.0) plasma : schedule_timeout (process_timeout)
3.5% ( 2.0) <kernel core> : clocksource_register (clocksource_watchdog)
1.8% ( 1.0) klipper : schedule_timeout (process_timeout)
1.4% ( 0.8) firefox : futex_wait (hrtimer_wakeup)
1.1% ( 0.6) <interrupt> : ata_piix

So you see that mplayer is causing lots of wakeups more than other players (mpg123 in this case, but it's the same even with Amarok). This might cause an unnecessary waste of power, so it would be great if someone could look into it.

Thanks.

Change History (3)

comment:1 Changed 11 years ago by luis6674@…

Just add that if I open the GUI (gmplayer) and leave it there idle (without playing anything) it already increases wakeups by about 60 per second.

comment:2 Changed 11 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

gmplayer is unmaintained, expect no improvements there.
Also keep in mind that MPlayer is first of all a movie/media player, decoding and processing half a second of audio at once like those pure audio players do is not an option, it would work very badly e.g. when switching the audio channel (of course even a pure audio file can have many audio tracks, but I think none of your other cited players even support that).
Nevertheless, 100 wakeups per seconds is admittedly excessive, and SVN r28220 improves this.
I now get 32 wakeups/s with and 12 wakeups/s without cache.
I am setting this to WONTFIX because improving it beyond that I think is not worthwhile for us.

comment:3 Changed 11 years ago by luis6674@…

Ah ok, if you've already looked into this and improved what could be improved then it's fine.

Thanks for the explanation.

Note: See TracTickets for help on using tickets.