Opened 11 years ago

Closed 10 years ago

#1371 closed defect (fixed)

forced subtitle display on playback with matroska + vobsub

Reported by: beandog@… Owned by: reimar
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc: wWolfovich@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

With r28035, when playing a MKV file encoded from a VOB (MPEG2 + AC3) + VOBSUB tracks, mplayer will automatically display the subtitles.

No amount of config options (-noautosub, etc.) will disable displaying them by default. The only way to turn them off is to toggle them off (hit 'j').

Uploaded mpeg2_ac3_vobsub_forced_subs.mkv and log into incoming/

Change History (7)

comment:1 Changed 11 years ago by beandog@…

Whoops, that was r28227.

comment:2 Changed 10 years ago by compn

  • Cc wWolfovich@… added

* Bug 1447 has been marked as a duplicate of this bug. *

comment:3 Changed 10 years ago by compn

-sid 999 should do it
in config or whatever :)

then using -sid or -slang or j / v key will turn subs on again.

comment:4 Changed 10 years ago by wWolfovich@…

(In reply to comment #3)

-sid 999 should do it
in config or whatever :)

then using -sid or -slang or j / v key will turn subs on again.

Yes it works for playback thanks, but realy it is only a workaround.
It have to be fixed.

comment:5 Changed 10 years ago by beandog@…

Reimar,

One reason that has been brought up before is that since the subtitle track is flagged as "default" then it should be showing up. Setting a track without the default flag still displays it by default as well, I've noticed.

$ mkvmerge -o movie.mkv movie.vob --default-track 0:no --forced-track 0:no movie.idx

$ mkvinfo test.mkv

+ EBML head
|+ Doc type: matroska
|+ Doc type version: 2
|+ Doc type read version: 2
+ Segment, size 947965685
|+ Seek head (subentries will be skipped)
|+ EbmlVoid? (size: 4027)
|+ Segment information
| + Timecode scale: 1000000
| + Muxing application: libebml v0.7.8 + libmatroska v0.8.1
| + Writing application: mkvmerge v2.9.0 ('Moanin) built on May 30 2009 08:12:50
| + Duration: 1333.818s (00:22:13.818)
| + Date: Sat May 30 15:18:18 2009 UTC
| + Segment UID: 0xbe 0xbb 0x8c 0x2f 0x84 0xd7 0x40 0xc5 0x71 0x26 0xe4 0x85 0x86 0xe6 0x1a 0x3b
|+ Segment tracks
| + A track
| + Track number: 1
| + Track UID: 987971060
| + Track type: video
| + Enabled: 1
| + Default flag: 1
| + Forced flag: 0
| + Lacing flag: 0
| + MinCache?: 2
| + Timecode scale: 1
| + Max BlockAddition? ID: 0
| + Codec ID: V_MPEG2
| + Codec decode all: 1
| + Default duration: 33.367ms (29.970 fps for a video track)
| + Language: und
| + Video track
| + Pixel width: 720
| + Pixel height: 480
| + Interlaced: 0
| + Display width: 640
| + Display height: 480
| + A track
| + Track number: 2
| + Track UID: 310572720
| + Track type: audio
| + Enabled: 1
| + Default flag: 1
| + Forced flag: 0
| + Lacing flag: 1
| + MinCache?: 0
| + Timecode scale: 1
| + Max BlockAddition? ID: 0
| + Codec ID: A_AC3
| + Codec decode all: 1
| + Default duration: 32.000ms (31.250 fps for a video track)
| + Language: und
| + Audio track
| + Sampling frequency: 48000
| + Channels: 1
| + A track
| + Track number: 3
| + Track UID: 2983775300
| + Track type: subtitles
| + Enabled: 1
| + Default flag: 0
| + Forced flag: 0
| + Lacing flag: 0
| + MinCache?: 0
| + Timecode scale: 1
| + Max BlockAddition? ID: 0
| + Codec ID: S_VOBSUB
| + Codec decode all: 1
| + CodecPrivate?, length 167
| + Language: eng
| + Content encodings
| + Content encoding
| + Order: 0
| + Scope: 1 (1: all frames)
| + Type: 0 (compression)
| + Content compression
| + Algorithm: 0 (ZLIB)
|+ EbmlVoid? (size: 1024)
|+ Cluster

comment:6 Changed 10 years ago by beandog@…

(In reply to comment #5)

<snip>

Gosh dang it ... another case of user error. It was loading the autosubs from the same directory.

So, to clarify, it *does* work correctly if you use mkvmerge with --default-track 0:no before the .idx file.

Whether that's odd that mkvmerge automatically flags subtitles as default or that mplayer automatically displays them is a matter of opinion at this point, I suppose.

comment:7 Changed 10 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed

this is fixed with -nosub option now.

Note: See TracTickets for help on using tickets.