Opened 11 years ago

Last modified 9 years ago

#1377 new defect

Fullscreen doesn't work on ctwm

Reported by: nyh@… Owned by: reimar
Priority: important Component: vo
Version: HEAD Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I'm using MPlayer dev-SVN-r27514-4.3.2. My machine has nvidia (with the proprietary driver) and vo defaults to "xv" which works perfectly (except the full-screen, as I'll explain now).

When running on the ctwm window manager (the latest release: 3.8a), "mplayer -fs" doesn't run full-screen, but rather opens a regular sized window.

After a lot of soul-searching (and blaming everything from nvidia to xvideo), I finally found a workaround: "mplayer -fstype none -fs" works!

Apparently, the non-ICCCM window-manager hints mplayer uses to open a full-screen window are not supported, or not supported correctly (I didn't check) in ctwm.

Please don't mark this down as merely a ctwm bug without testing it first, for several reasons. First, it's a new bug (I previously used a 1.5 year-old version of mplayer, I don't remember the version, and it didn't have this problem). Second, the problem is probably not specific to ctwm and maybe occurs in other "old-school" window managers as well (see possibly related 25). Finally, since "-fstype none" works around this problem, perhaps the logic of how "fstype" decides if the fullscreen methods it tried is broken, and the code should have realised that the tricks it tried did *not* work and used the "none" method instead (I guess just one big override-redirect window?)

Thanks,
Nadav.

Change History (1)

comment:1 Changed 9 years ago by compn

  • Owner changed from beastd to reimar
Note: See TracTickets for help on using tickets.