Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1378 closed defect (fixed)

incorrect and missing reports during and after compile process

Reported by: stranche@… Owned by: diego@…
Priority: normal Component: build system
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

here are some infos you can see during the compile process, first at ./configure :

Checking for CPU type ... Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
Checking for kernel support of mmx ... yes
Checking for kernel support of mmxext ... yes
Checking for kernel support of sse ... yes
Checking for kernel support of sse2 ... yes
Checking for kernel support of ssse3 ... yes
Checking for kernel support of cmov ... yes

as you can see, the SSE infos says "ssse3" instead of "sse3"

Then after the MPlayer binary is build :

CPU: Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz (Family: 6, Model: 15, Stepping: 11)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

There's no report of MMXEXT (or is it MMX2 ? some inconsistancy here), SSE3 and CMOV

Are they just not being show in the infos or are they forgotten during the 'make' process and the binary not optimised ?

Change History (11)

comment:1 Changed 11 years ago by diego@…

  • Status changed from new to assigned

(In reply to comment #0)

here are some infos you can see during the compile process, first at
./configure :

Checking for CPU type ... Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
Checking for kernel support of mmx ... yes
Checking for kernel support of mmxext ... yes
Checking for kernel support of sse ... yes
Checking for kernel support of sse2 ... yes
Checking for kernel support of ssse3 ... yes
Checking for kernel support of cmov ... yes

as you can see, the SSE infos says "ssse3" instead of "sse3"

SSSE3 is correct.

Then after the MPlayer binary is build :

CPU: Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz (Family: 6, Model: 15,
Stepping: 11)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

There's no report of MMXEXT (or is it MMX2 ? some inconsistancy here), SSE3
and CMOV

MMX2 and MMXEXT are the same thing.

Are they just not being show in the infos or are they forgotten during the
'make' process and the binary not optimised ?

Just not shown. I'll fix this soon.

comment:2 Changed 11 years ago by diego@…

  • Resolution set to fixed
  • Status changed from assigned to closed

Fix committed.

comment:3 Changed 11 years ago by stranche@…

(In reply to comment #2)

Fix committed.

Huh ?!
Did you really committed it in the SVN tree ? I did just try and nothing changed.

comment:4 Changed 11 years ago by diego@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

(In reply to comment #3)

(In reply to comment #2)

Fix committed.

Huh ?!
Did you really committed it in the SVN tree ? I did just try and nothing
changed.

Sorry, I confused this with another bug...

comment:5 Changed 11 years ago by diego@…

  • Resolution set to fixed
  • Status changed from reopened to closed

Fix committed.

comment:6 Changed 11 years ago by stranche@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

(In reply to comment #5)

Fix committed.

Something's wrong captain, I just compiled SVN and now the report of CPU flags just isn't here anymore ...

And as you can see there's a \n in the middle of the first sentence

MPlayer SVN-r28378-4.3.2 (C) 2000-2009 MPlayer Team\nCPU: Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz (Family: 6, Model: 15, Stepping: 11)
Usage: mplayer [options] [url|path/]filename

Basic options: (complete list in the man page)
<...>

comment:7 Changed 11 years ago by diego@…

  • Resolution set to fixed
  • Status changed from reopened to closed

Try MPLAYER_VERBOSE=1 ./mplayer

Yes, it's gone on purpose..

comment:8 Changed 11 years ago by stranche@…

(In reply to comment #7)

Try MPLAYER_VERBOSE=1 ./mplayer

Yes, it's gone on purpose..

Oh, okay it's better now.

However what about the line break left ?

$ MPLAYER_VERBOSE=1 mplayer
MPlayer SVN-r28378-4.3.2 (C) 2000-2009 MPlayer Team\nCPU vendor name: GenuineIntel? max cpuid level: 10

See, the \n

comment:9 Changed 11 years ago by diego@…

(In reply to comment #8)

However what about the line break left ?

$ MPLAYER_VERBOSE=1 mplayer
MPlayer SVN-r28378-4.3.2 (C) 2000-2009 MPlayer Team\nCPU vendor name:
GenuineIntel? max cpuid level: 10

See, the \n

I keep hearing that, but I cannot reproduce it. I need some details about your system...

comment:10 Changed 11 years ago by stranche@…

(In reply to comment #9)

I keep hearing that, but I cannot reproduce it. I need some details about your
system...

Okay, what do you need to know ?

Hardware is :
Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz (for this computer I'm on now)
Xorg driver is Intel (integrated chipset)

OS is : Ubuntu 8.10 + updates up-to-date

comment:11 Changed 11 years ago by diego@…

(In reply to comment #10)

(In reply to comment #9)

I keep hearing that, but I cannot reproduce it. I need some details about
your system...

Okay, what do you need to know ?

Hardware is :
Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz (for this computer I'm on now)
Xorg driver is Intel (integrated chipset)

OS is : Ubuntu 8.10 + updates up-to-date

It was an obscure issue about different shells reacting differently to \n, but it is fixed now.

Note: See TracTickets for help on using tickets.