Opened 11 years ago

Closed 10 years ago

#1407 closed defect (fixed)

mplayer segfaults after pausing if it cannot reacquire sound devices with OSS audio plugin

Reported by: thierry.vignaud@… Owned by: reimar
Priority: normal Component: ao
Version: unspecified Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

On both x86 and x86_64, mplayer segfaults after pausing if it cannot reacquire sound devices with OSS audio plugin.
This happens for a long time (tested with both 1.0-1.rc2 and r28387 snapshot).

See GDB trace at https://qa.mandriva.com/attachment.cgi?id=12258

GDB show that it hapylly tries FD_SET() an invalid file descriptor because it hadn't tested whether open() failed or not (returning -1).
Despite having detected that situation:

Fatal error: * CANNOT RE-OPEN / RESET AUDIO DEVICE * Device or resource busy
Program received signal SIGSEGV, Segmentation fault.
0x0812327f in get_space () at libao2/ao_oss.c:509
509 FD_SET(audio_fd, &rfds);

Change History (1)

comment:1 Changed 10 years ago by thierry.vignaud@…

  • Resolution set to fixed
  • Status changed from new to closed

Looks like this was fixed at some point since r31086 loooks OK

Note: See TracTickets for help on using tickets.