Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#143 closed defect (fixed)

rtsp:// url does not fail back to port 7070 when 554 times out

Reported by: compn Owned by: r_togni@…
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

if an rtsp server times out with port 554, it should retry with port 7070
dunno if this is in the RFC but its like that mms 1755/80/8080 crap.

port 7070 on this stream works.

Playing rtsp://video.c-span.org/project/digital/digitalfuture111504.rm.
Filename for url is now rtsp://video.c-span.org/project/digital/digitalfuture111504.rm
WINSOCK2 init: 0
Filename for url is now rtsp://video.c-span.org/project/digital/digitalfuture111504.rm
Resolving video.c-span.org for AF_INET...
Connecting to server video.c-span.org[12.170.145.134]:554 ...
Connection timeout
Not a Realmedia rtsp url. Trying standard rtsp protocol.
RTSP support requires the "LIVE.COM Streaming Media" libraries!
Unable to open URL: rtsp://video.c-span.org/project/digital/digitalfuture111504.rm

Attachments (1)

network.c.diff (670 bytes) - added by r_togni@… 15 years ago.
Try this!

Download all attachments as: .zip

Change History (5)

Changed 15 years ago by r_togni@…

Try this!

comment:1 Changed 15 years ago by r_togni@…

  • Owner changed from alex@… to r_togni@…
  • Status changed from new to assigned

comment:2 Changed 15 years ago by r_togni@…

Try patch from previous comment; it works for me, but i get a coeection refused
instead of a timeout.

This patch works only if connection to 554 fails, if it's successful and rtsp
session setup fails it doesn't have any effect (i have another patch ready if
it's needed with some other server).

It does not attempt to connect to 7070 if the user forced connection on a
specific port.

comment:3 Changed 15 years ago by compn

patch works for me! thanks rxt.

comment:4 Changed 15 years ago by r_togni@…

  • Resolution set to fixed
  • Status changed from assigned to closed

Committed.

Note: See TracTickets for help on using tickets.