Opened 10 years ago

Closed 8 years ago

#1445 closed defect (fixed)

choppy playback for ts file

Reported by: compn Owned by: reimar
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

pasted from email:

This is a DVB-S2 TS Stream, h264. The Stream was recorded 1:1 from Sat-
Receiver to HD.

It playbacks choppy and looks like some frames are dropped. And Audio/Video? is
not in sync, if i only use mplayer without "tweaks".

mplayer -demuxer lavf -vc ffh264 -correct-pts Der\ goldene\ Kompass.ts -mc 100
-delay -0.0

Is the only way to playback the Video.

incoming/choppy-playback-test1080i.ts

Change History (2)

comment:1 Changed 8 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:2 Changed 8 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Sample is no longer available but this is probably the timestamp issue with interlaced that was solved some time ago.

Note: See TracTickets for help on using tickets.