Opened 10 years ago

Last modified 9 years ago

#1456 closed defect (duplicate)

Mencoder rips subtitles with wrong timestamps

Reported by: Walter.MMM@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc2 Severity: normal
Keywords: Cc: Walter.MMM@…, thedamocles@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I'am trying to rip subtitles using mencoders integrated subtitlesripper. But the current timestamp is smaller than the previous one. The result is a wrong order for some subtitle entries. Some subtitles are not displayed when playing the film.

The error is reproducable. I have used two versions of mplayer
MPlayer dev-SVN-r27637
MPlayer dev-SVN-r29116

o show you what I mean i copied the log (I have marked the lines)

# VobSub? index file, v7 (do not modify this line!)
#
# Generated by MPlayer dev-SVN-r29116-4.3-openSUSE Linux 11.1 (i686)-Packman
# See <URL:http://www.mplayerhq.hu/> for more information about MPlayer
# See <URL:http://vobsub.edensrising.com/> for more information about Vobsub
#
size: 720x576
palette: 101010, 101010, 101010, 101010, 101010, 101010, 101010, 101010, 101010, 101010, 101010, 101010, 101010, bfbfbf, 101010, 101010
# ON: displays only forced subtitles, OFF: shows everything
forced subs: OFF

# Language index in use
langidx: 0

id: de, index: 0
timestamp: 00:00:00:080, filepos: 000000000
timestamp: 00:01:56:600, filepos: 000000800
timestamp: 00:01:58:919, filepos: 000001000
timestamp: 00:02:01:479, filepos: 000001800
timestamp: 00:02:05:239, filepos: 000002000
timestamp: 00:02:07:040, filepos: 000002800
timestamp: 00:02:11:560, filepos: 000003800
timestamp: 00:02:13:359, filepos: 000004000
timestamp: 00:02:13:360, filepos: 000005000
timestamp: 00:02:19:279, filepos: 000005800
timestamp: 00:02:19:280, filepos: 000006000
timestamp: 00:02:31:760, filepos: 000006800
timestamp: 00:02:35:559, filepos: 000007800
timestamp: 00:02:37:279, filepos: 000008000
timestamp: 00:02:40:519, filepos: 000008800
timestamp: 00:02:43:440, filepos: 000009800
timestamp: 00:02:47:959, filepos: 00000a000
timestamp: 00:02:56:760, filepos: 00000a800
timestamp: 00:03:01:959, filepos: 00000b800
timestamp: 00:03:03:199, filepos: 00000c000
timestamp: 00:03:04:400, filepos: 00000c800
timestamp: 00:03:05:839, filepos: 00000d000
timestamp: 00:03:05:840, filepos: 00000d800
timestamp: 00:03:09:400, filepos: 00000e000
timestamp: 00:03:12:519, filepos: 00000f000
timestamp: 00:03:12:520, filepos: 00000f800
timestamp: 00:03:16:000, filepos: 000010000
timestamp: 00:03:17:920, filepos: 000011000
timestamp: 00:03:21:640, filepos: 000012000 here
timestamp: 00:03:21:639, filepos: 000012800
timestamp: 00:03:23:640, filepos: 000013000
timestamp: 00:03:25:480, filepos: 000014000
timestamp: 00:03:28:839, filepos: 000015000
timestamp: 00:03:30:399, filepos: 000015800
timestamp: 00:03:32:079, filepos: 000016000
timestamp: 00:03:33:840, filepos: 000016800
timestamp: 00:03:36:119, filepos: 000017000
timestamp: 00:03:41:399, filepos: 000017800
timestamp: 00:03:43:960, filepos: 000018000
timestamp: 00:03:47:279, filepos: 000019000
timestamp: 00:03:51:839, filepos: 00001a000
timestamp: 00:03:53:119, filepos: 00001a800
timestamp: 00:03:54:479, filepos: 00001b000
timestamp: 00:03:59:200, filepos: 00001b800
timestamp: 00:04:05:760, filepos: 00001c000 here
timestamp: 00:04:05:759, filepos: 00001c800
timestamp: 00:04:08:800, filepos: 00001d000
timestamp: 00:04:08:799, filepos: 00001d800
timestamp: 00:04:21:919, filepos: 00001e000
timestamp: 00:04:24:320, filepos: 00001e800 here
timestamp: 00:04:24:319, filepos: 00001f000
timestamp: 00:04:26:239, filepos: 00001f800
timestamp: 00:04:27:360, filepos: 000020000
timestamp: 00:04:27:359, filepos: 000020800 here
timestamp: 00:04:30:679, filepos: 000021000
timestamp: 00:04:39:719, filepos: 000022000
timestamp: 00:04:49:120, filepos: 000023000
timestamp: 00:04:52:920, filepos: 000024000
timestamp: 00:04:58:120, filepos: 000024800
timestamp: 00:05:01:839, filepos: 000025000
timestamp: 00:05:13:199, filepos: 000026000
timestamp: 00:05:13:200, filepos: 000026800
timestamp: 00:05:17:759, filepos: 000027000
timestamp: 00:05:17:760, filepos: 000027800
timestamp: 00:05:19:839, filepos: 000028000
timestamp: 00:05:19:840, filepos: 000028800
timestamp: 00:05:22:119, filepos: 000029000
timestamp: 00:05:24:839, filepos: 00002a000
timestamp: 00:05:24:840, filepos: 00002a800
timestamp: 00:05:31:200, filepos: 00002b000
timestamp: 00:05:32:679, filepos: 00002b800
timestamp: 00:05:34:119, filepos: 00002c000
timestamp: 00:05:35:159, filepos: 00002d000
timestamp: 00:05:35:160, filepos: 00002d800
timestamp: 00:05:37:920, filepos: 00002e000
timestamp: 00:05:37:919, filepos: 00002e800 here
timestamp: 00:05:40:240, filepos: 00002f000
timestamp: 00:05:41:759, filepos: 00002f800
timestamp: 00:05:43:839, filepos: 000030800
timestamp: 00:05:57:799, filepos: 000031800
timestamp: 00:05:59:880, filepos: 000032800
timestamp: 00:06:04:039, filepos: 000033000
timestamp: 00:06:06:960, filepos: 000033800
timestamp: 00:06:08:039, filepos: 000034000
timestamp: 00:06:09:479, filepos: 000034800
timestamp: 00:06:52:159, filepos: 000035800
timestamp: 00:06:55:799, filepos: 000036000
timestamp: 00:07:54:520, filepos: 000036800 here
timestamp: 00:07:55:920, filepos: 000037000
timestamp: 00:08:21:959, filepos: 000037800
timestamp: 00:08:25:040, filepos: 000038000

Some informations about my operating system:

donjuan@linux-i1ku:~> uname -a
Linux linux-i1ku 2.6.27.21-0.1-pae #1 SMP 2009-03-31 14:50:44 +0200 i686 athlon i386 GNU/Linux

donjuan@linux-i1ku:~> ls -l /lib/libc[.-]*
-rwxr-xr-x 1 root root 1419604 22. Feb 13:45 /lib/libc-2.9.so
lrwxrwxrwx 1 root root 11 20. Mär 11:12 /lib/libc.so.6 -> libc-2.9.so

donjuan@linux-i1ku:~> gcc -v
Using built-in specs.
Target: i586-suse-linux
Configured with: ../configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib --libexecdir=/usr/lib --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.3 --enable-ssp --disable-libssp --with-bugurl=http://bugs.opensuse.org/ --with-pkgversion='SUSE Linux' --disable-libgcj --disable-libmudflap --with-slibdir=/lib --with-system-zlib --enable-cxa_atexit --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --enable-version-specific-runtime-libs --program-suffix=-4.3 --enable-linux-futex --without-system-libunwind --with-cpu=generic --build=i586-suse-linux
Thread model: posix
gcc version 4.3.2 [gcc-4_3-branch revision 141291] (SUSE Linux)

donjuan@linux-i1ku:~> ld -v
GNU ld (GNU Binutils; openSUSE 11.1) 2.19

donjuan@linux-i1ku:~> as --version
GNU assembler (GNU Binutils; openSUSE 11.1) 2.19
Copyright 2007 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License version 3 or later.
This program has absolutely no warranty.
This assembler was configured for a target of `i586-suse-linux'.

donjuan@linux-i1ku:~> cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 16
model : 2
model name : AMD Phenom(tm) 9850 Quad-Core Processor
stepping : 3
cpu MHz : 1250.000
cache size : 512 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 4
apicid : 0
initial apicid : 0
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs
bogomips : 5000.33
clflush size : 64
power management: ts ttp tm stc 100mhzsteps hwpstate

processor : 1
vendor_id : AuthenticAMD
cpu family : 16
model : 2
model name : AMD Phenom(tm) 9850 Quad-Core Processor
stepping : 3
cpu MHz : 1250.000
cache size : 512 KB
physical id : 0
siblings : 4
core id : 1
cpu cores : 4
apicid : 1
initial apicid : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs
bogomips : 5000.39
clflush size : 64
power management: ts ttp tm stc 100mhzsteps hwpstate

processor : 2
vendor_id : AuthenticAMD
cpu family : 16
model : 2
model name : AMD Phenom(tm) 9850 Quad-Core Processor
stepping : 3
cpu MHz : 1250.000
cache size : 512 KB
physical id : 0
siblings : 4
core id : 2
cpu cores : 4
apicid : 2
initial apicid : 2
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tscpni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs
bogomips : 5000.40
clflush size : 64
power management: ts ttp tm stc 100mhzsteps hwpstate

processor : 3
vendor_id : AuthenticAMD
cpu family : 16
model : 2
model name : AMD Phenom(tm) 9850 Quad-Core Processor
stepping : 3
cpu MHz : 1250.000
cache size : 512 KB
physical id : 0
siblings : 4
core id : 3
cpu cores : 4
apicid : 3
initial apicid : 3
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tscpni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs
bogomips : 5000.39
clflush size : 64
power management: ts ttp tm stc 100mhzsteps hwpstate

thank you

Walter

Change History (2)

comment:1 Changed 9 years ago by thedamocles@…

  • Resolution set to duplicate
  • Status changed from new to closed, thedamocles@gmail.com

This bug is a duplicate of 1853 : I mark this one as duplicate because the bug 1853 already has a patch attached…

comment:2 Changed 9 years ago by thedamocles@…

After another reading, maybe the two bug are slightly different, but I think they are linked and their solution should be provided by the same patch.

But I can be wrong…

Note: See TracTickets for help on using tickets.