Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1458 closed defect (invalid)

musepack loop

Reported by: compn Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc: reimar, ant0nski@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

incoming/musepack_sv8_ape2.mpc

C:\Program Files\MPlayer for Windows>mplayer -msglevel all=7 "d:\TestSamples?\Aud
io\Axel Rudi Pell sv8.mpc"
Adding file d:\TestSamples?\Audio\Axel Rudi Pell sv8.mpc
Config pushed level is now 2
Config pushed level is now 3
MPlayer Sherpya-SVN-r29238-4.5.0 (C) 2000-2009 MPlayer Team
CPU vendor name: GenuineIntel? max cpuid level: 10
CPU: Intel(R) Core(TM)2 CPU 6420 @ 2.13GHz (Family: 6, Model: 15, Step
ping: 6)
extended cpuid-level: 8
extended cache-info: 268468288
Detected cache-line size is 64 bytes
Testing OS support for SSE... yes.
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSSE3: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2 CMOV
get_path('codecs.conf') -> 'C:/Program Files/MPlayer for Windows/mplayer/codecs.
conf'
Reading C:/Program Files/MPlayer for Windows/mplayer/codecs.conf: Can't open 'C:
/Program Files/MPlayer for Windows/mplayer/codecs.conf': No such file or directo
ry
Reading /usr/etc/mplayer/codecs.conf: Can't open '/usr/etc/mplayer/codecs.conf':

No such file or directory

Using built-in default codecs.conf.
Configuration: --extra-cflags=-I/c/Work/mplayer/live --prefix=/usr --enable-stat
ic --enable-md5sum --enable-menu --disable-vdpau --disable-vidix --disable-sdl -
-enable-caca --enable-gl --enable-matrixview --enable-freetype --enable-png --en
able-mng --enable-jpeg --enable-gif --enable-tga --enable-mad --enable-tv --enab
le-theora --disable-dvb --disable-dvbhead --enable-libamr_nb --enable-libamr_wb
--flavor=p4
CommandLine?: '-msglevel' 'all=7' 'd:\TestSamples?\Audio\Axel Rudi Pell sv8.mpc'
init_freetype
get_path('font/font.desc') -> 'C:/Program Files/MPlayer for Windows/mplayer/font
/font.desc'
font: can't open file: C:/Program Files/MPlayer for Windows/mplayer/font/font.de
sc
font: can't open file: /usr/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
get_path('fonts') -> 'C:/Program Files/MPlayer for Windows/mplayer/fonts'
Using Windows native timing
get_path('input.conf') -> 'C:/Program Files/MPlayer for Windows/mplayer/input.co
nf'
Parsing input config file C:/Program Files/MPlayer for Windows/mplayer/input.con
f
Input config file C:/Program Files/MPlayer for Windows/mplayer/input.conf parsed
: 90 binds
get_path('d:\TestSamples?\Audio\Axel Rudi Pell sv8.mpc.conf') -> 'C:/Program File
s/MPlayer for Windows/mplayer/d:\TestSamples?\Audio\Axel Rudi Pell sv8.mpc.conf'

[init getch2?]

Playing d:\TestSamples?\Audio\Axel Rudi Pell sv8.mpc.
get_path('sub/') -> 'C:/Program Files/MPlayer for Windows/mplayer/sub/'
WINSOCK2 init: 0
WINSOCK2 init: 0
[file] File size is 1078530 bytes
STREAM: [file] d:\TestSamples?\Audio\Axel Rudi Pell sv8.mpc
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
LAVF_check: Musepack SV8
libavformat file format detected.
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
mp_seek(01D5F058, 1078353, 0)
177=mp_read(01D5F058, 01D5FA04, 32768), eof:1
mp_seek(01D5F058, 46, 0)
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
mp_seek(01D5F058, 0, 65536)
==> Found audio stream: 0
[lavf] Audio stream found, -aid 0
======= WAVE Format =======
Format Tag: 20557 (0x504D)
Channels: 2
Samplerate: 44100
avg byte/sec: 0
Block align: 1
bits/sample: 16
cbSize: 2
Unknown extra header dump: [1b] [1b]
==========================================================================
LAVF: 1 audio and 0 video streams found
LAVF: build 3416064
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
dec_audio: Allocating 192000 + 65536 = 257536 bytes for output buffer.
FFmpeg's libavcodec audio codec
INFO: libavcodec init OK!
demux_lavf_fill_buffer()
AUDIO: 44100 Hz, 2 ch, s16le, 0.0 kbit/0.00% (ratio: 0->176400)
Selected audio codec: [ffmusepack8] afm: ffmpeg (Musepack sv8 audio codec)
==========================================================================
Building audio filter chain for 44100Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Trying every known audio driver...
ao_dsound: Output Devices:
0 Primary Sound Driver <--
1 SoundMAX HD Audio O
2 USB Sound Device (emulated)
ao_dsound: DirectSound? initialized
ao_dsound: Samplerate:44100Hz Channels:2 Format:s16le
ao_dsound: Buffersize:176400 bytes (1000 msec)
ao_dsound: primary buffer created
ao_dsound: secondary (stream)buffer created
AO: [dsound] 44100Hz 2ch s16le (2 bytes per sample)
AO: Description: Windows DirectSound? audio output
AO: Author: Gabor Szecsi <deje@…>
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Video: no video
Freeing 0 unused video chunks.
Starting playback...
Increasing filtered audio buffer size from 0 to 65536
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
37449=mp_read(01D5F058, 01DCE4BF, 37449), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
35498=mp_read(01D5F058, 01DCD6D1, 35498), eof:0
demux_lavf_fill_buffer()
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
32768=mp_read(01D5F058, 01D5FA04, 32768), eof:0
demux_lavf_fill_buffer()
22497=mp_read(01D5F058, 01D5FA04, 32768), eof:1
demux_lavf_fill_buffer()
demux_lavf_fill_buffer()
ds_fill_buffer: EOF reached (stream: audio)
demux_lavf_fill_buffer()
demux_lavf_fill_buffer()
mp_seek(01D5F058, 1078567, 0)
stream_seek: WARNING! Can't seek to 0x107527 !
mp_seek(01D5F058, 1078579, 0)
stream_seek: WARNING! Can't seek to 0x107031 !
mp_seek(01D5F058, 1078577, 0)
stream_seek: WARNING! Can't seek to 0x10702F !
mp_seek(01D5F058, 1078565, 0)
stream_seek: WARNING! Can't seek to 0x107023 !
mp_seek(01D5F058, 1078591, 0)
stream_seek: WARNING! Can't seek to 0x10703D !

MPlayer interrupted by signal 2 in module: decode_audio

Change History (6)

comment:1 Changed 10 years ago by ant0nski@…

Helo,

The problem is still present with:
MPlayer Sherpya-SVN-r29355-4.5.0 (C) 2000-2009 MPlayer Team

I've uploaded new test samples at Mediafire, will be there for 7 days:

  1. http://www.mediafire.com/download.php?ykzdnofmu2i - SV8 file without tags, plays fine
  2. http://www.mediafire.com/download.php?dnrtd2qnzzo - SV8 file with tags, endless loop at the eof
  3. http://www.mediafire.com/download.php?jn3iu5jn5kz - SV8 file with tags ang chapters, same problems

Best regards

  1. Angov

comment:2 Changed 10 years ago by reimar

  • Cc Reimar.Doeffinger@… added
  • Resolution set to invalid
  • Status changed from new to closed

Fixed in FFmpeg SVN r20099.
Since the issue was in FFmpeg and not MPlayer itself, setting this to invalid.
Not sure if there might be additional issues with those files (e.g. not playing till the end) though.

comment:3 Changed 10 years ago by ant0nski@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

I'm afraid the problem is not solved, although the output looks a bit different at the end. I've tested with the latest version MPlayer Sherpya-SVN-r29355-4.5.0

comment:4 Changed 10 years ago by ant0nski@…

  • Cc ant0nski@… added

Adding file d:\TestSamples?\Axel Rudi Pell sv8.mpc
Config pushed level is now 2
Config pushed level is now 3
MPlayer Sherpya-SVN-r29355-4.5.0 (C) 2000-2009 MPlayer Team
CPU vendor name: GenuineIntel? max cpuid level: 10
CPU: Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz (Family: 6, Model: 15, Stepping: 11)
extended cpuid-level: 8
extended cache-info: 268468288
Detected cache-line size is 64 bytes
Testing OS support for SSE... yes.
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSSE3: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2 CMOV
get_path('codecs.conf') -> 'C:/Program Files/MPlayer/mplayer/codecs.conf'
Reading C:/Program Files/MPlayer/mplayer/codecs.conf: Can't open 'C:/Program Files/MPlayer/mplayer/codecs.conf': No such file or directory
Reading /usr/etc/mplayer/codecs.conf: Can't open '/usr/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
Configuration: --extra-cflags=-I/c/Work/mplayer/live --prefix=/usr --enable-static --enable-md5sum --enable-menu --disable-vdpau --disable-vidix --disable-sdl --enable-caca --enable-gl --enable-matrixview --enable-freetype --enable-png --enable-mng --enable-jpeg --enable-gif --enable-tga --enable-mad --enable-tv --enable-theora --disable-dvb --disable-dvbhead --enable-libamr_nb --enable-libamr_wb --flavor=p4
CommandLine?: '-msglevel' 'all=7' 'd:\TestSamples?\Axel Rudi Pell sv8.mpc'
init_freetype
get_path('font/font.desc') -> 'C:/Program Files/MPlayer/mplayer/font/font.desc'
font: can't open file: C:/Program Files/MPlayer/mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
get_path('fonts') -> 'C:/Program Files/MPlayer/mplayer/fonts'
Using Windows native timing
get_path('input.conf') -> 'C:/Program Files/MPlayer/mplayer/input.conf'
Parsing input config file C:/Program Files/MPlayer/mplayer/input.conf
Input config file C:/Program Files/MPlayer/mplayer/input.conf parsed: 90 binds
get_path('d:\TestSamples?\Axel Rudi Pell sv8.mpc.conf') -> 'C:/Program Files/MPlayer/mplayer/d:\TestSamples?\Axel Rudi Pell sv8.mpc.conf'

[init getch2?]

Playing d:\TestSamples?\Axel Rudi Pell sv8.mpc.
get_path('sub/') -> 'C:/Program Files/MPlayer/mplayer/sub/'
WINSOCK2 init: 0
WINSOCK2 init: 0
[file] File size is 1078582 bytes
STREAM: [file] d:\TestSamples?\Axel Rudi Pell sv8.mpc
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
LAVF_check: Musepack SV8
libavformat file format detected.
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
mp_seek(09D93D40, 1078353, 0)
229=mp_read(09D93D40, 09D9D7C4, 32768), eof:1
mp_seek(09D93D40, 46, 0)
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
mp_seek(09D93D40, 0, 65536)
==> Found audio stream: 0
[lavf] Audio stream found, -aid 0
======= WAVE Format =======
Format Tag: 20557 (0x504D)
Channels: 2
Samplerate: 44100
avg byte/sec: 0
Block align: 1
bits/sample: 16
cbSize: 2
Unknown extra header dump: [1b] [1b]
==========================================================================
LAVF: 1 audio and 0 video streams found
LAVF: build 3416576
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
dec_audio: Allocating 1130496 + 65536 = 1196032 bytes for output buffer.
FFmpeg's libavcodec audio codec
INFO: libavcodec init OK!
demux_lavf_fill_buffer()
AUDIO: 44100 Hz, 2 ch, s16le, 0.0 kbit/0.00% (ratio: 0->176400)
Selected audio codec: [ffmusepack8] afm: ffmpeg (Musepack sv8 audio codec)
==========================================================================
Building audio filter chain for 44100Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Trying every known audio driver...
ao_dsound: Output Devices:
0 Primary Sound Driver <--
1 Conexant HD Audio output
ao_dsound: DirectSound? initialized
ao_dsound: Samplerate:44100Hz Channels:2 Format:s16le
ao_dsound: Buffersize:176400 bytes (1000 msec)
ao_dsound: primary buffer created
ao_dsound: secondary (stream)buffer created
AO: [dsound] 44100Hz 2ch s16le (2 bytes per sample)
AO: Description: Windows DirectSound? audio output
AO: Author: Gabor Szecsi <deje@…>
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Video: no video
Freeing 0 unused video chunks.
Starting playback...
Increasing filtered audio buffer size from 0 to 65536
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
37449=mp_read(09D93D40, 09DD393F, 37449), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
35498=mp_read(09D93D40, 09DAEC91, 35498), eof:0
demux_lavf_fill_buffer()
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
32768=mp_read(09D93D40, 09D9D7C4, 32768), eof:0
demux_lavf_fill_buffer()
22549=mp_read(09D93D40, 09D9D7C4, 32768), eof:1
demux_lavf_fill_buffer()
demux_lavf_fill_buffer()
ds_fill_buffer: EOF reached (stream: audio)
demux_lavf_fill_buffer()
demux_lavf_fill_buffer()

MPlayer interrupted by signal 2 in module: decode_audio
C

comment:5 Changed 10 years ago by reimar

  • Resolution set to invalid
  • Status changed from reopened to closed

Even if the bug was still there, the issue is in FFmpeg, thus it would still be mostly pointless to report it here.
And r29355 sure as hell isn't the latest version, it is more than 4 months old, the current revision is r29773 which means there were over 400 changes in MPlayer alone and probably a whole lot more in FFmpeg.
There might be a newer MPlayer binary version at
http://mulder.dummwiedeutsch.de/home/?page=projects#mplayer
but I don't know for sure, if not you'll just have to wait, but don't reopen unless you have tested with a version no older that start of October (r29744).

comment:6 Changed 10 years ago by ant0nski@…

Sorry for the misconception, I was using the latest Mulder's release dated 2009-10-12.
Thank you for your time.

Note: See TracTickets for help on using tickets.