Opened 10 years ago

Last modified 9 years ago

#1462 new defect

ffmpeg audio codec crashes mplayer-29274 build with gcc4.4 and not with gcc4.3.3

Reported by: chok@… Owned by: reimar
Priority: very important Component: demuxer
Version: unspecified Severity: normal
Keywords: Cc: chok@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Using SVN revision 29274 on Archlinux x86_64 with 2.6.29 stock arch kernel
output of ls -l /lib/libc[.-]*
-rwxr-xr-x 1 root root 1618912 avril 30 04:19 /lib/libc-2.9.so
lrwxrwxrwx 1 root root 11 avril 30 04:19 /lib/libc.so.6 -> libc-2.9.so

I tested gcc 4.4
Utilisation des specs internes.
Target: x86_64-unknown-linux-gnu
Configuré avec: ../configure --prefix=/usr --enable-shared --enable-languages=c,c++,fortran,objc,obj-c++ --enable-threads=posix --mandir=/usr/share/man --infodir=/usr/share/info --enable-cxa_atexit --disable-multilib --libdir=/usr/lib --libexecdir=/usr/lib --enable-clocale=gnu --disable-libstdcxx-pch --with-tune=generic
Modèle de thread: posix
gcc version 4.4.0 (GCC)

$ ld -v
GNU ld (GNU Binutils) 2.19.1.20090418

as --version
GNU assembler (GNU Binutils) 2.19.1.20090418

And gcc 4.3
$ gcc -v
Utilisation des specs internes.
Target: x86_64-unknown-linux-gnu
Configuré avec: ../configure --prefix=/usr --enable-shared --enable-languages=c,c++,fortran,objc,obj-c++,treelang --enable-threads=posix --mandir=/usr/share/man --infodir=/usr/share/info --enable-cxa_atexit --disable-multilib --libdir=/usr/lib --libexecdir=/usr/lib --enable-clocale=gnu --disable-libstdcxx-pch --with-tune=generic
Modèle de thread: posix
gcc version 4.3.3 (GCC)

$ ld -v
GNU ld (GNU Binutils) 2.19.1.20090205

$ as --version
GNU assembler (GNU Binutils) 2.19.1.20090205

The revision 29274 build with gcc4.4.0 exits when loading ffmpeg audio codec
the log file is here: http://pastebin.archlinux.fr/347149 (for one month)
reproductible with vorbis (i tested with vorbis and ffvorbis decoder) and with aac audio.
I am sure it's audio related: I stripped the subtitles, still crash, I reencoded the audio to mp3 and mplayer played the file fine (tested with mp3lib and mad).
Building mplayer revision 29274 with the same ./configure and gcc 4.3.3 works fine.

Change History (6)

comment:1 Changed 10 years ago by chok@…

  • Cc chok@… added

I forgot to add, I rebuild ffmpeg with gcc 4.4.0 (the arch revision 17395 from february)
and ffplay the aac/vorbis files works fine

comment:2 Changed 10 years ago by chok@…

Actually, it seemed related to mkv produced by the mkvtoolnix suite : I used Avidemux to transcode audio to mp3 and mux into mkv --> no crash.

I used an xvid + mp3 file playable through my buggy mplayer and remux it with mkvtoolnix --> crash. I will updated everything and conduct more thorough test.

Also something weird, when I tried to recompile with --enable-debug=3 the .mkv files worked correctly, I recompiled with enable-debug=1 and then no enable debug flag, but it didn't work anymore.

comment:3 Changed 10 years ago by chok@…

  • Component changed from ao to demuxer
  • Owner changed from reimar to r_togni@…

Forgot to add, the --enable-debug thing happened with mplayer svn rev 29308.

I'll reassigned this bug to demuxer but it may actually be a compiler problem.

comment:4 Changed 10 years ago by compn

pasting log here incase it goes awaay from paste site:

usr/bin/mplayer *05*
MPlayer SVN-r29271-4.4.0 (C) 2000-2009 MPlayer Team
137 codecs audio & 296 codecs vidéo
Lecture de [Eclipse]_Full_Metal_Alchemist_Brotherhood_-_01_(1280x720)_[70C1405D].mkv
[mkv] Ident. piste 1 : video (V_MPEG4/ISO/AVC) "Full Metal Alchemist Brotherhood - 01", -vid 0
[mkv] Ident. piste 2 : audio (A_VORBIS) "2.0 Vorbis", -aid 0, -alang jpn
[mkv] Ident. piste 3 : subtitles (S_TEXT/ASS) "ASS", -sid 0, -slang eng
[mkv] Ident. piste 4 : subtitles (S_TEXT/UTF8) "SRT", -sid 1, -slang eng
[mkv] Jouera piste vidéo 1.
Fichier de type Matroska détecté.
VIDEO: [avc1] 1280x720 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Ouverture du décodeur vidéo : [ffmpeg] FFmpeg's libavcodec codec family
Codec vidéo choisi : [ffh264] vfm : ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Ouverture décodeur audio : [ffmpeg] FFmpeg/libavcodec audio decoders


MPlayer interrompu par le signal 11 dans le module : init_audio_codec

  • MPlayer a planté à cause d'une mauvaise utilisation de CPU/FPU/RAM. Recompilez MPlayer avec --enable-debug et faites un backtrace 'gdb' et désassemblage. Détails : DOCS/HTML/fr/bugreports_what.html#bugreports_crash
  • MPlayer a planté. Cela n'aurait pas dû arriver. Peut-être un bogue dans code de MPlayer _ou_ dans vos pilotes _ou_ dans votre version de gcc. C'est la faute de MPlayer ? Lire DOCS/HTML/fr/bugreports.html et suivre les instructions. Nous pourrons et voudrons vous aider si vous fournissiez ces informations en rapportant un bogue possible.

i'm guessing gcc problem if you cant reproduce in debug mode. gcc 4.4 has had some problems w/ mplayer.

comment:5 Changed 10 years ago by shiragumo@…

when compiling with gcc 4.4.x you need to use the flag "-fno-strict-aliasing" in CFLAGS

comment:6 Changed 9 years ago by compn

  • Owner changed from r_togni@… to reimar
Note: See TracTickets for help on using tickets.