Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#147 closed defect (fixed)

mkv file plays with incorrect audio

Reported by: gabor@… Owned by: alex@…
Priority: normal Component: af
Version: HEAD Severity: normal
Keywords: Cc: jasmin-bugs@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

http://z10n.net/i.mkv

a 4mbyte sample.

the audio is played in mplayer only in one of the speakers (only-left or
only-right, i don't remember exactly ;).
but when played back for example in videolan player, it plays correctly (both
speakers).

btw. how big an attached file can be? is 4mbytes still allowed?

Attachments (3)

mplayer.log (7.2 KB) - added by gabor@… 15 years ago.
mplayer -v log
i.mkv (496.8 KB) - added by gabor@… 15 years ago.
problematic.mkv
mplayer.2.log (16.2 KB) - added by gabor@… 15 years ago.
mplayer-v.log

Download all attachments as: .zip

Change History (9)

Changed 15 years ago by gabor@…

mplayer -v log

comment:1 Changed 15 years ago by gabor@…

Changed 15 years ago by gabor@…

problematic.mkv

comment:2 Changed 15 years ago by gabor@…

i remuxed the problematic file, so now it is smaller (only 500kbytes), and it's
only 3seconds long, so you can spot the problem immediately.

Changed 15 years ago by gabor@…

mplayer-v.log

comment:3 Changed 15 years ago by gabor@…

  • attachments.isobsolete changed from 0 to 1

i created a new mplayer logfile. made with the new i.mkv, and today's
mplayer-cvs.

comment:4 Changed 15 years ago by dominik@…

  • Status changed from new to assigned

Verified, looks like - unlike AC3 - AAC 6chn audio is not downmixed properly.

comment:5 Changed 15 years ago by dominik@…

  • Cc jasmin-bugs@… added

* Bug 157 has been marked as a duplicate of this bug. *

comment:6 Changed 14 years ago by moritz@…

  • Resolution set to fixed
  • Status changed from assigned to closed

There have been commits to mplayer recently that implement channel downmixing
for AAC, too. So this sample plays fine for me now.

Note: See TracTickets for help on using tickets.