Opened 10 years ago

Closed 10 years ago

#1484 closed defect (invalid)

audio broken (falls silent for very short to very long periods) for many Internet radio streams

Reported by: axst@… Owned by: reynaldo@…
Priority: normal Component: af
Version: unspecified Severity: normal
Keywords: Cc: axst@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Package: mplayer
Version: 1:1.0.rc2svn20080706-0.1lenny1
Severity: important

When playing the following streams, the player often encounters errors which can only be resolved by a restart. I think they may be due to network problems or load on my side or the server's side. Unfortunately the player seems not to recognize this. In the best case it just fails, saying "End of file", then I can just automatically restart it using a script. In many cases, though, there is just no output anymore or the sound breaks up. But as long as the player does not react at all I cannot do anything in the script. Setting cache values higher or lower does not change this behaviour. But my aim is to have the stream played and restarted if necessary without intervention. Proxy settings do not affect this behaviour either.

mms://a814.l961736813.c9617.g.lm.akamaistream.net/D/814/9617/v0001/reflector:36813

http://radio3.cbc.ca/nmcradio/webradio.m3u = http://shoutcast1.cbcradio3.com/

(There are more if you need them.)

-- System Information:
Debian Release: 5.0.1

APT prefers stable
APT policy: (500, 'stable')

Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=UTF-8) (ignored: LC_ALL set to en_US.utf8)
Shell: /bin/sh linked to /bin/bash

Versions of packages mplayer depends on:
ii libaa1 1.4p5-37+b1 ascii art library
ii libamrnb3 7.0.0.2-0.1 floating-point Adaptive Multi-Rate
ii libamrwb3 7.0.0.3-0.0 Adaptive Multi-Rate - Wideband (AM
ii libartsc0 1.5.9-2 aRts sound system C support librar
ii libasound2 1.0.16-2 ALSA library
ii libatk1.0-0 1.22.0-1 The ATK accessibility toolkit
ii libaudio2 1.9.1-5 Network Audio System - shared libr
ii libaudiofile0 0.2.6-7 Open-source version of SGI's audio
ii libc6 2.7-18 GNU C Library: Shared libraries
ii libcaca0 0.99.beta14-1 colour ASCII art library
ii libcairo2 1.6.4-7 The Cairo 2D vector graphics libra
ii libcdparanoia0 3.10.2+debian-5 audio extraction tool for sampling
ii libcucul0 0.99.beta14-1 low-level Unicode character drawin
ii libdirectfb-1.0-0 1.0.1-11 direct frame buffer graphics - sha
ii libdv4 1.0.0-1+b1 software library for DV format dig
ii libesd0 0.2.36-3 Enlightened Sound Daemon - Shared
ii libfaac0 1.26-0.2 an AAC audio encoder - library fil
ii libfontconfig1 2.6.0-3 generic font configuration library
ii libfreetype6 2.3.7-2+lenny1 FreeType? 2 font engine, shared lib
ii libfribidi0 0.10.9-1 Free Implementation of the Unicode
ii libgcc1 1:4.3.2-1.1 GCC support library
ii libggi2 1:2.2.2-3 General Graphics Interface runtime
ii libfaac0 1.26-0.2 an AAC audio encoder - library fil
ii libfontconfig1 2.6.0-3 generic font configuration library
ii libfreetype6 2.3.7-2+lenny1 FreeType? 2 font engine, shared lib
ii libfribidi0 0.10.9-1 Free Implementation of the Unicode
ii libgcc1 1:4.3.2-1.1 GCC support library
ii libggi2 1:2.2.2-3 General Graphics Interface runtime
ii libgif4 4.1.6-6 library for GIF images (library)
ii libgl1-mesa-glx [lib 7.0.3-7 A free implementation of the OpenG
ii libglib2.0-0 2.16.6-1+lenny1 The GLib library of C routines
ii libgtk2.0-0 2.12.12-1~lenny1 The GTK+ graphical user interface
ii libjack0 0.109.2-5 JACK Audio Connection Kit (librari
ii libjpeg62 6b-14 The Independent JPEG Group's JPEG
ii liblircclient0 0.8.3-3 infra-red remote control support -
ii liblzo2-2 2.03-1 data compression library
ii libmad0 0.15.1b-4 MPEG audio decoder library
ii libmpcdec3 1.2.2-1 Musepack (MPC) format library
ii libncurses5 5.7+20081213-1 shared libraries for terminal hand
ii libogg0 1.1.3-4 Ogg Bitstream Library
ii libopenal1 1:1.4.272-2 Software implementation of the Ope
ii libpango1.0-0 1.20.5-3+lenny1 Layout and rendering of internatio
ii libpng12-0 1.2.27-2+lenny2 PNG library - runtime
ii libpulse0 0.9.10-3 PulseAudio? client libraries
ii libsdl1.2debian 1.2.13-2 Simple DirectMedia? Layer
ii libsmbclient 2:3.2.5-4lenny2 shared library that allows applica
ii libspeex1 1.2~rc1-1 The Speex codec runtime library
ii libstdc++6 4.3.2-1.1 The GNU Standard C++ Library v3
ii libsvga1 1:1.4.3-27 console SVGA display libraries
ii libtheora0 1.0~beta3-1 The Theora Video Compression Codec
ii libvorbis0a 1.2.0.dfsg-3.1 The Vorbis General Audio Compressi
ii libx11-6 2:1.1.5-2 X11 client-side library
ii libx264-65 1:0.svn20090115-0.0 x264 video coding library
ii libxext6 2:1.0.4-1 X11 miscellaneous extension librar
ii libxinerama1 2:1.0.3-2 X11 Xinerama extension library
ii libxt6 1:1.0.5-3 X11 toolkit intrinsics library
ii libxv1 2:1.0.4-1 X11 Video extension library
ii libxvidcore4 2:1.1.3-0.6 High quality ISO MPEG4 codec libra
ii libxvmc1 1:1.0.4-2 X11 Video extension library
ii libxxf86dga1 2:1.0.2-1 X11 Direct Graphics Access extensi
ii libxxf86vm1 1:1.0.2-1 X11 XFree86 video mode extension l
ii mplayer-skin-blue [m 1.6-2 blue skin for mplayer
ii zlib1g 1:1.2.3.3.dfsg-12 compression library - runtime

MPlayer dev-SVN-r26940
CPU: Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz (Family: 6, Model: 23, Stepping: 10)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
mdb:48, lastbuf:0 skipping granule 0
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [ffmp3] afm: ffmpeg (FFmpeg MPEG layer-3 audio decoder)

Change History (6)

comment:1 Changed 10 years ago by compn

how long into the stream until this occurs generally?

comment:2 Changed 10 years ago by compn

btw i would suggest you just script it to kill / restart mplayer every X number of hours if you cant find a better solution.

comment:3 Changed 10 years ago by axst@…

(In reply to comment #1)

how long into the stream until this occurs generally?

(In reply to comment #2)

btw i would suggest you just script it to kill / restart mplayer every X number
of hours if you cant find a better solution.

I received this by e-mail too but my replies seem not to have arrived, that's why I include them here:

#1
It may occur right away (after a split-second) or after hours. I am sorry. First I thought it might be ao but local audio and video files pose no problem at all.

#2
Thanks for the suggestion. Unfortunately the dropouts occur quite randomly. At this moment I am listening to a stream without any interruptions that M Player does not recognise, and with only two interruptions that were recognized --- "Exiting... (End of file)" --- in one and a half hours. Sometimes these unrecognized dropouts occur every few seconds and last from anywhere between a split second and total silence until I kill M PLayer :-( --- and even then they come back (this why I think it may have something to with load somewhere along the connection). So there is no regular time interval I could use in the script.

comment:4 Changed 10 years ago by axst@…

  • Cc axst@… added

Reactions of other players (Totem, G Xine) to compare:

  • In most cases they stop for less than half a second, then show "buffering" and quickly resume playback. This is the appropriate reaction in case an error occurs. Unfortunately these players use a GUI even though there is no video. This is one of the big advantages of M Player --- it won't do anything you don't need it to.
  • In some cases they stopped playback with an error message complaining about a read error from the URL. In these cases playback only resumed when the play button was pressed. The players did not close down however so that playback could not be resumed using the script. This is another reason why I would like to use M PLayer.

Here is another URL: http://www.cbc.ca/livemedia/cbcr2-toronto.m3u

comment:5 Changed 10 years ago by axst@…

Through trial and error, I have identified the cause of the problem: my Internet connection was swamped because I had failed to limit the upload bandwidth used by some other programs. After a strict limit was imposed, the problems on the audio streams disappeared.

It seems that M Player could not handle the errors produced by my overloaded broadband router. A dedicated error message ("missing packets", "malformed packets") would have been a great help.

comment:6 Changed 10 years ago by reynaldo@…

  • Resolution set to invalid
  • Status changed from new to closed

-> Invalid. Not that I'm saying we rock at streaming in bad conditions
but still, the way its pictured here its not bugwise-correct.

Note: See TracTickets for help on using tickets.