Opened 11 years ago

Closed 9 years ago

#1502 closed defect (worksforme)

Can't install MPlayer with GUI under OpenSolaris 2009.06

Reported by: ptecza@… Owned by: diego@…
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I've configured and compiled successfully the latest version
of MPlayer under OpenSolaris? 2009.06. It was built against GUI
support (GTK2).

$ ./configure --prefix=/opt/mplayer --enable-gui
$ gmake

Unfortunately I can't install it now:

$ pfexec gmake install
install -d /opt/mplayer/bin /opt/mplayer/etc/mplayer /opt/mplayer/lib
install -m 755 -s mplayer /opt/mplayer/bin
ln -sf mplayer /opt/mplayer/bin/gmplayer
install -d /opt/mplayer/share/mplayer/skins /opt/mplayer/share/pixmaps /opt/mplayer/share/applications
directory /opt/mplayer/share/mplayer/skins created
install -m 644 etc/mplayer.xpm /opt/mplayer/share/pixmaps/
find: stat() error /opt/mplayer/share/pixmaps/: No such file or directory
find: cycle detected for /lib/32/
find: cycle detected for /lib/crypto/32/
find: cycle detected for /lib/secure/32/
find: cycle detected for /usr/lib/locale/en_US.UTF-8/32/
find: cycle detected for /usr/lib/locale/en_US.UTF-8/LO_LTYPE/32/
find: cycle detected for /usr/lib/locale/en_US.UTF-8/LC_CTYPE/32/
find: cycle detected for /usr/lib/link_audit/32/
find: cycle detected for /usr/lib/32/
find: cycle detected for /usr/lib/secure/32/
find: cycle detected for /usr/lib/elfedit/32/
find: cycle detected for /usr/lib/lwp/32/
install: mplayer.xpm was not found anywhere!
gmake: * [install-gui] Error 2

I created manually a missing /opt/mplayer/share/pixmaps/ directory,
but it's not sufficient:

$ ls -ld /opt/mplayer/share/pixmaps/
ls: cannot access /opt/mplayer/share/pixmaps/: No such file or directory

$ pfexec mkdir /opt/mplayer/share/pixmaps/

$ pfexec gmake install
install -d /opt/mplayer/bin /opt/mplayer/etc/mplayer /opt/mplayer/lib
install -m 755 -s mplayer /opt/mplayer/bin
ln -sf mplayer /opt/mplayer/bin/gmplayer
install -d /opt/mplayer/share/mplayer/skins /opt/mplayer/share/pixmaps /opt/mplayer/share/applications
install -m 644 etc/mplayer.xpm /opt/mplayer/share/pixmaps/
find: cycle detected for /lib/32/
find: cycle detected for /lib/crypto/32/
find: cycle detected for /lib/secure/32/
find: cycle detected for /usr/lib/locale/en_US.UTF-8/32/
find: cycle detected for /usr/lib/locale/en_US.UTF-8/LO_LTYPE/32/
find: cycle detected for /usr/lib/locale/en_US.UTF-8/LC_CTYPE/32/
find: cycle detected for /usr/lib/link_audit/32/
find: cycle detected for /usr/lib/32/
find: cycle detected for /usr/lib/secure/32/
find: cycle detected for /usr/lib/elfedit/32/
find: cycle detected for /usr/lib/lwp/32/
install: mplayer.xpm was not found anywhere!
gmake: * [install-gui] Error 2

I'm quite sure that mplayer.xpm file exists, because I can find it :)

$ find . -type f -name mplayer.xpm
./etc/mplayer.xpm

Any ideas?

Change History (4)

comment:1 Changed 11 years ago by ptecza@…

(In reply to comment #0)

Unfortunately I can't install it now:

$ pfexec gmake install
install -d /opt/mplayer/bin /opt/mplayer/etc/mplayer /opt/mplayer/lib
install -m 755 -s mplayer /opt/mplayer/bin
ln -sf mplayer /opt/mplayer/bin/gmplayer
install -d /opt/mplayer/share/mplayer/skins /opt/mplayer/share/pixmaps
/opt/mplayer/share/applications
directory /opt/mplayer/share/mplayer/skins created
install -m 644 etc/mplayer.xpm /opt/mplayer/share/pixmaps/

As you can see above, Solaris install -d command can't create
more then one directory. It make only first directory and omits
the rest. Below is yet another test to confirm that observation:

$ ls /opt/mplayer/share/
man mplayer pixmaps
$ pfexec rm -rf /opt/mplayer/share/pixmaps/

$ ls /opt/mplayer/share/
man mplayer

$ pfexec install -d /opt/mplayer/share/pixmaps/ /opt/mplayer/share/applications/
directory /opt/mplayer/share/pixmaps/ created

$ ls /opt/mplayer/share/
man mplayer pixmaps

I know it sucks, but probably we need to invoke install -d command
3 times to create 3 directories... :)

install -m 644 etc/mplayer.xpm /opt/mplayer/share/pixmaps/
find: cycle detected for /lib/32/
find: cycle detected for /lib/crypto/32/
find: cycle detected for /lib/secure/32/
find: cycle detected for /usr/lib/locale/en_US.UTF-8/32/
find: cycle detected for /usr/lib/locale/en_US.UTF-8/LO_LTYPE/32/
find: cycle detected for /usr/lib/locale/en_US.UTF-8/LC_CTYPE/32/
find: cycle detected for /usr/lib/link_audit/32/
find: cycle detected for /usr/lib/32/
find: cycle detected for /usr/lib/secure/32/
find: cycle detected for /usr/lib/elfedit/32/
find: cycle detected for /usr/lib/lwp/32/
install: mplayer.xpm was not found anywhere!
gmake: * [install-gui] Error 2

I guess it's next example of incompatibility of Solaris install tool.
Its manual says:

This version of install (/usr/sbin/install) is not compati-
ble with the install binaries in many versions of Unix other
than Solaris. For a higher degree of compatibility with
other Unix versions, use /usr/ucb/install, which is
described in the install(1B) man page.

Unfortunately I don't have installed /usr/ucb/install and probably
many OpenSolaris? users don't have it too.

comment:2 Changed 11 years ago by ptecza@…

(In reply to comment #1)

I guess it's next example of incompatibility of Solaris install tool.
Its manual says:

This version of install (/usr/sbin/install) is not compati-
ble with the install binaries in many versions of Unix other
than Solaris. For a higher degree of compatibility with
other Unix versions, use /usr/ucb/install, which is
described in the install(1B) man page.

Unfortunately I don't have installed /usr/ucb/install and probably
many OpenSolaris? users don't have it too.

Probably I've found solution. Can we use ginstall instead of
install? It seems it works good under OpenSolaris?:

$ ls /opt/mplayer/share/
man mplayer pixmaps

$ pfexec rm -rf /opt/mplayer/share/pixmaps/

$ ls /opt/mplayer/share/
man mplayer

$ pfexec ginstall -d /opt/mplayer/share/pixmaps/ /opt/mplayer/share/applications/

$ ls /opt/mplayer/share/
applications man mplayer pixmaps

$ pfexec ginstall -m 644 etc/mplayer.xpm /opt/mplayer/share/pixmaps/

$ ls -l /opt/mplayer/share/pixmaps/
total 6
-rw-r--r-- 1 root root 5495 2009-06-27 01:20 mplayer.xpm

comment:3 Changed 11 years ago by ptecza@…

(In reply to comment #2)

Probably I've found solution. Can we use ginstall instead of
install? It seems it works good under OpenSolaris?:

I've just discovered --with-install option of configure script :D

Diego, what's the best solution for Solaris install issue in your
opinion? Should we use --with-install=ginstall or use mkdir && cp
instead of install utility to install MPlayer with GUI under
(Open)Solaris?

comment:4 Changed 9 years ago by diego@…

  • rep_platform changed from PC (x86 with MMX) to All
  • Resolution set to worksforme
  • Status changed from new to closed

Use the --with-install option of configure.

Note: See TracTickets for help on using tickets.