Opened 10 years ago

Closed 10 years ago

#1506 closed defect (invalid)

freetype-config is not used

Reported by: dogcow+bugzilla@… Owned by: diego@…
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

./configure has a --with-freetype-config= option, but it's not actually used anywhere; indeed, the test program doesn't bother calling freetype-config at all, but merely uses the default set of include and linker paths. This is somewhat annoying, especially as it requires fiddling with CFLAGS to work around.

Change History (2)

comment:1 Changed 10 years ago by diego@…

  • Status changed from new to assigned

freetype-config *is* being used in the FreeType? configure check. What is your problem exactly, I cannot reproduce any issues...

comment:2 Changed 10 years ago by dogcow+bugzilla@…

  • Resolution set to invalid
  • Status changed from assigned to closed

Ugh. My grep-fu wasn't working that day. Turns out my bug was related to freetype-config itself having bad values in it, and old freetype1 header files causing test program compilation to fail.

Note: See TracTickets for help on using tickets.