Opened 10 years ago

Last modified 9 years ago

#1517 closed defect (worksforme)

DVDNAV subtitle issue

Reported by: fragabr@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: HEAD Severity: normal
Keywords: Cc: compn, c_kruk@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

1) working example (using only dvd://):

mplayer -slang pt dvd://24

shows subtitle even after seeking through the video

2) non-working example (using dvdnav://):

mplayer -slang pt dvdnav://24

doesn't show the subtitle, unless I select by hand. And if I

seek through the video, it doesn't show anymore the subtitle.

*

"pt" is the subtitle number 2.

In the second case (dvdnav://), although mplayer selects

correctly the subtitle "pt" (I know because if I cycle through the
subtitles, it jumps directly to the next one, number "3") it doesn't
show the subtitle until I start to cycle through the subtitles.

It seems to be a bug in stream_dvdnav.c.

Any hints? Thanks.

Attachments (1)

workaround-reimar.patch (239 bytes) - added by fragabr@… 10 years ago.
Just a workaround (this is not the solution yet)

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by fragabr@…

Just a workaround (this is not the solution yet)

comment:1 Changed 10 years ago by fragabr@…

It can break something else, but at least solves the issue.

comment:2 Changed 10 years ago by fragabr@…

  • attachments.mimetype changed from application/octet-stream to text/plain

comment:3 Changed 9 years ago by compn

  • Cc c_kruk@… added

comment:4 Changed 9 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed, patriotact@gmail.com

could not reproduce. does this happen with all dvds? all languages?

Note: See TracTickets for help on using tickets.