Opened 14 years ago

Closed 12 years ago

#152 closed defect (fixed)

mplayer does not accept smil and other playlists on rtsp://

Reported by: compn Owned by: r_togni@…
Priority: normal Component: streaming
Version: HEAD Severity: normal
Keywords: Cc: pvdharanjm@…, jasonthomasdolan@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

mplayer 's realrtsp code only handles rm, needs support for .smil and other
playlist and other container formats...

Change History (7)

comment:1 Changed 14 years ago by jasonthomasdolan@…

Indeed. Another example of a SMIL playlist that should be supported can be
obtained by clicking on any track at http://hooj.com.

comment:2 Changed 14 years ago by jasonthomasdolan@…

  • Cc jasonthomasdolan@… added

comment:3 Changed 14 years ago by jasonthomasdolan@…

e.g. http://www.city16.com/audiobox.cgi?track=dfc007b.rm&review=dfc007

It seems as tho these SMIL lists incorporate swf video, and I'm unsure if that's
*supposed* to be supported by mplayer, but regardless..it should play the audio
track (RealPlayer? 8).

comment:4 Changed 14 years ago by r_togni@…

  • Cc pvdharanjm@… added

comment:5 Changed 14 years ago by r_togni@…

* Bug 205 has been marked as a duplicate of this bug. *

comment:6 Changed 13 years ago by diego@…

  • Component changed from core to streaming

comment:7 Changed 12 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed

roberto just added support for this into svn.

thanks!

Note: See TracTickets for help on using tickets.