Opened 10 years ago

Last modified 8 years ago

#1522 new defect

wmv timestamp starts at +5 in mplayer but not wmp

Reported by: alexo.veto@… Owned by: reimar
Priority: normal Component: vd
Version: unspecified Severity: normal
Keywords: Cc: compn, basinilya@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

with same files mplayer start show first frame at 5 second position
(this make broken subtitle timing)

i have subtitle with right timing(xine, gstream - work correct),
but in mplayer need to shift subtitle timing (-5 seconds)

files start play at first frame, but mplayer OSD show position 00:00:05

mplayer '/home/media/HxH_RAW_TV/2/Hunter X Hunter 02.wmv' -utf8
MPlayer dev-SVN-r29116-4.3-openSUSE Linux 11.1 (i686)-Packman (C) 2000-2009 MPlayer TeamCan?'t open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: Connection refused
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/media/HxH_RAW_TV/2/Hunter X Hunter 02.wmv.
ASF file format detected.
[asfheader] Audio stream found, -aid 1
[asfheader] Video stream found, -vid 2
VIDEO: [WMV3] 640x480 24bpp 1000.000 fps 1125.0 kbps (137.3 kbyte/s)
Clip info:

name: 第2話 出会い×とまどい×出航
author:
copyright: 冨樫義博・フジテレビ/日本アニメーション
comments: 脚本:岸間信明

演出:宮下新平
絵コンテ:安積惣一
作画監督:加藤政広
SUB: Detected subtitle file format: subviewer
SUB: Read 236 subtitles.
SUB: Adjusted 5 subtitle(s).
SUB: Added subtitle file (1): /home/media/HxH_RAW_TV/2/Hunter X Hunter 02.srt
Opening video filter: [scale]
[ass] auto-open
[ass] Init
[ass] Updating font cache.
==========================================================================
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
Decoder supports the following formats: YV12 YUY2 UYVY YVYU RGB8 RGB555 RGB565 RGB24 RGB32
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 640 x 480 (preferred colorspace: Packed YUY2)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
[swscaler @ 0x9065ab0]using unscaled yuv420p -> bgr24 special converter
VO: [gl2] 640x480 => 640x480 BGR 24-bit [zoom]
[gl2] You have OpenGL >= 1.2 capable drivers, GOOD (16bpp and BGR is ok!)
[gl2] antialiasing off
[gl2] bilinear linear
Selected video codec: [wmv9dmo] vfm: dmo (Windows Media Video 9 DMO)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 15994->192000)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[ass] PlayResX undefined, setting 384.

Attachments (1)

01.wmv (1000.0 KB) - added by alexo.veto@… 10 years ago.
this is an example - part of video file (first 5 second)

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by alexo.veto@…

* Bug 1523 has been marked as a duplicate of this bug. *

comment:2 Changed 10 years ago by alexo.veto@…

* Bug 1524 has been marked as a duplicate of this bug. *

comment:3 Changed 10 years ago by alexo.veto@…

* Bug 1525 has been marked as a duplicate of this bug. *

comment:4 Changed 10 years ago by alexo.veto@…

* Bug 1526 has been marked as a duplicate of this bug. *

comment:5 Changed 10 years ago by alexo.veto@…

* Bug 1527 has been marked as a duplicate of this bug. *

comment:6 Changed 10 years ago by alexo.veto@…

* Bug 1528 has been marked as a duplicate of this bug. *

comment:7 Changed 10 years ago by alexo.veto@…

Oops.
i'm sorry by duplicate

Changed 10 years ago by alexo.veto@…

this is an example - part of video file (first 5 second)

comment:8 Changed 10 years ago by alexo.veto@…

mplayer played this file incorrectly - start show first frame at 5 second position,
just open this file in mplayer and see to OSD

(also, some files start at 10 second position)

comment:9 Changed 8 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:10 Changed 8 years ago by compn

  • Cc patriotact@… added
  • Summary changed from with same files mplayer start show first frame at 5 second position(this make broken subtitle timing) to wmv timestamp starts at +5 in mplayer but not wmp

workaround use -subdelay 5

comment:11 Changed 8 years ago by compn

  • Cc basinilya@… added
Note: See TracTickets for help on using tickets.