Opened 10 years ago

Closed 10 years ago

#1529 closed defect (invalid)

Upgrade installer system crash

Reported by: peter.strempel1@… Owned by: diego@…
Priority: important Component: build system
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When saying yes to autoupdater for MPlayer with SMPlayer front end to MPlayer 2009-07-24 build #61 (complete installation), it hung the system (Dell GX240, Pentium 4, 1GB RAM, 20Gb free disk space on C drive, running Windows 2003 server)after reaching the stage of "creating folder c:\documents and settings\all users\start menu\programs\MPlayer for Win..." (rest of message not visible in installation dialogue).

Other programs running at the time of installation were utorrent and Symantec anti-virus.

Was unable to terminate installation process or run any diagnostics, but processor appeared to run at 100% for 20 minutes before hard re-boot which automatically loaded chkdsk (checkdisk) and deleted nsb9D.tmp from index $I30, recovered orphaned files nsj9B.tmp, MPUI.ini, smplayer.ini. I'm no programmer but I'm guessing that my system had a problem handling the creation and reading of installation temp files.

Autoreboot followed and when system came up the following error message was displayed: "The system registry hive has been corrupted and recovered. Some data might have been lost."

Too early to tell whether there really was any registry corruption. I am not game to repeat the installation process again for fear of further and or irreperable damage to the registry. SMPlayer now reports as Version: 0.6.8 (SVN r3213). Using Qt 4.5.2 (compiled with Qt 4.5.1). Using MPlayer SVN r29355. Does this mean my upgrade succeeded?

Change History (3)

comment:1 Changed 10 years ago by diego@…

  • Resolution set to invalid
  • Status changed from new to closed
  • Summary changed from Upgrade insdtaller system crash to Upgrade installer system crash

This is not related to MPlayer.

comment:2 Changed 10 years ago by peter.strempel1@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

(In reply to comment #1)

This is not related to MPlayer.

On what basis is the assessment made that the problem is not related to MPlayer? Is it too much to ask for at least a summary reasoning rather than a summary unreasoned dismissal?

Is it your contention that the auto-installer is not an MPlayer issue, or is it the case that you believe the auto-installer did not cause a system crash? In either case, or some other reasoning, what is that reasoning? Being contemptuous of questions not addressed in any documentation seems arrogant rather than knowledgeable.

comment:3 Changed 10 years ago by john.vansickle@…

  • Resolution set to invalid
  • Status changed from reopened to closed

(In reply to comment #2)

(In reply to comment #1)

This is not related to MPlayer.

On what basis is the assessment made that the problem is not related to
MPlayer? Is it too much to ask for at least a summary reasoning rather than a
summary unreasoned dismissal?

Is it your contention that the auto-installer is not an MPlayer issue, or is it
the case that you believe the auto-installer did not cause a system crash? In
either case, or some other reasoning, what is that reasoning? Being
contemptuous of questions not addressed in any documentation seems arrogant
rather than knowledgeable.

Peter,

SMPlayer is third party software and isn't supported by MPlayer devs. You'll have to take this issue up with the SMPlayer developers.

Note: See TracTickets for help on using tickets.