Opened 15 years ago

Closed 13 years ago

Last modified 13 years ago

#153 closed defect (worksforme)

Gmplayer crash when trying to handle a particular (just-released) DVD

Reported by: mplayer@… Owned by: reimar
Priority: important Component: GUI
Version: unspecified Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Note: this may or may not be a dupe of bug 12, which looks similar, although his
bug crashed every time where mine is specific to one DVD. I'll let those who
are smarter than me decide if this is the case =]

How it crashed:
Went to video store and rented a newly-released DVD from a major studio for my
daughter to watch. Ran gmplayer from the commandline, went to the right-click
menu, opened the DVD by right-click, DVD, Open Disk. The playback window turns
black, resizes a couple of times, and then returns to the opening mplayer image.

Another right-click raises sig11. This happens pretty much every time,

although I can sometimes get it to play OK by opening up another DVD first,
stopping playback, changing disks, and then playing the one that crashes in the
same session, although I have to select the correct title from the DVD menu in
this case - it doesn't automatically start playback. I'm a little bit concerned
that the studios have come up with some other DRM cruft, but I don't have the
chops to know.

Details, details:
Distro: Ubuntu Hoary, updated earlier today via dist-upgrade.
Kernel: 2.6.8.1-3-386
libc version: 2.3.2
gcc version 3.3.5 (Debian 1:3.3.5-2)
GNU ld version 2.15
GNU assembler 2.15
GTK version: 2.5.5 (apparently - I could be wrong here, using synaptic to see
libgtk version installed)
glib version: 2.5.7
libpng version: 1.2.8
$ cat /proc/cpuinfo

processor : 0
vendor_id : GenuineIntel?
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 2.66GHz
stepping : 9
cpu MHz : 2666.931
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid
bogomips : 5292.03

Vidcard: GF 5900FX
Driver: Nvidia 1.0-6111
Soundcard: SBLive with ALSA OSS emulation

Attachments (1)

gmplayer.bug (12.3 KB) - added by mplayer@… 15 years ago.
Coredump using suggested values

Download all attachments as: .zip

Change History (11)

Changed 15 years ago by mplayer@…

Coredump using suggested values

comment:1 Changed 15 years ago by mplayer@…

comment:2 Changed 15 years ago by mplayer@…

Oh, I forgot to mention the title that I'm having trouble with: Shreck 2. My
daughter is vastly disappointed.

comment:3 Changed 15 years ago by mplayer@…

Oy, crikey, forgot to mention the mplayer version: snapshot 20041107
Sorry 'bout that.

comment:4 Changed 15 years ago by reimar

from your log:
AO: [plugin]
You use an -aop option. This is deprecated and IMHO should have been removed
some time ago as it is completely broken. Also you haven't said if you use ARTS.
ARTS in its current version seems to be quite broken.

comment:5 Changed 15 years ago by mplayer@…

Hmm. I am passing no flags either at compile or runtime. For compiling, the
only options I passed in this case were --enable-gui and --enable-debug=3.

I try and kill arts whenever I see it... however, can you think of a case for
arts causing the segfault only in the case of certain DVDs?

comment:6 Changed 15 years ago by mplayer@…

I sure wish bugzilla would provide an "edit" function, as it is in my nature to
be forgetful. I forgot to mention my commandline for launching gmplayer:
gmplayer

Or, when running it under gdb:
gdb
exec-file /usr/local/bin/gmplayer
run

It would seem that -aop is being hardwired into the binary somehow.

comment:7 Changed 15 years ago by mplayer@…

Just to verify: with arts confirmed down, and all else being the same, the
segfault occurs on one specific DVD title and no others in my library. This
particular DVD is a factory-issue that I need to return to the video store this
evening, not some bittorrent thing. I did try various means to strip out
various DRM, and the result is identical. I >really< think there's something
new in there...

comment:8 Changed 15 years ago by reimar

Just to ask explicitly: can you play the DVD with the command-line mplayer? If
yes, for a (temporary) solution you could try one of the other MPlayer
frontends, listed in the related projects page.
Also I guess that you have the equalizer enabled. If so, deactivate it (should
be possible somehow, but I don't remember how exactly) and try again and post
the log.

comment:9 Changed 13 years ago by diego@…

  • Component changed from core to GUI
  • Owner changed from alex@… to Reimar.Doeffinger@…

comment:10 Changed 13 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

Don't have any of these problems and quite a bit of gui code has changed. Some
dvd handling code changed as well, and mplayer dvdnav:// is available, too.
Please reopen if problems persist with a newer MPlayer version, and also report
non-gui behaviour.

Note: See TracTickets for help on using tickets.