Opened 9 years ago

Closed 9 years ago

#1565 closed defect (worksforme)

Mplayer can't play TrueHD-audio

Reported by: russianneuromancer@… Owned by: r_togni@…
Priority: very important Component: demuxer
Version: 1.0rc2 Severity: critical
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

No any sound, when I try to play video with only TrueHD-tracks (without ac3 in TrueHD stream).
Two samples: http://sharebee.com/b2269f57

Change History (5)

comment:1 Changed 9 years ago by compn

did you try with newer mplayer?
rc2 came out before truehd existed...

rc2 is very old.

comment:2 Changed 9 years ago by russianneuromancer@…

I try build ca17d1f-f29b3d9 from http://kovensky.project357.com/
I think this build enough fresh.

comment:3 Changed 9 years ago by compn

works here:

D:\>mplayera "TrueHD Sample 1 (Final Fantasy VII Advent Children).mkv"
MPlayer SVN-r29522-3.4.5 (C) 2000-2009 MPlayer Team
SSE2 supported but disabled
138 audio & 312 video codecs
c:\winnt\fonts\comic.ttf doesn't look like a bitmap font description, ignoring.
Cannot load bitmap font: c:\winnt\fonts\comic.ttf

Playing TrueHD Sample 1 (Final Fantasy VII Advent Children).mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_TRUEHD), -aid 0, -alang und
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [avc1] 1280x720 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
dvdsublang...truehd sample 1 final fantasy vii advent children en eng
dvdsublang...truehd sample 1 final fantasy vii advent children en eng
dvdsublang...truehd sample 1 final fantasy vii advent children en eng
dvdsublang...truehd sample 1 final fantasy vii advent children en eng
dvdsublang...truehd sample 1 final fantasy vii advent children en eng
Opening video filter: [eq]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Compiler did not align stack variables. Libavcodec has been miscompiled
and may be very slow or crash. This is not a bug in libavcodec,
but in the compiler. You may try recompiling using gcc >= 4.2.
Do not report crashes to FFmpeg developers.
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Stream parameters not seen; skipping frame.
[truehd @ 0pcbe010]Extracting 2 channel downmix from substream 0. Further substreams will be skippe
d.
AUDIO: 48000 Hz, 2 ch, s32le, 0.0 kbit/0.00% (ratio: 0->384000)
Selected audio codec: [fftruehd] afm: ffmpeg (FFmpeg TrueHD)
==========================================================================
AO: [dsound] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[truehd @ 0pcbe010]Extracting 2 channel downmix from substream 0. Further substreams will be skippe
d.
VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [directx] 1280x720 => 1280x720 Planar YV12
A: 0.4 V: 0.0 A-V: 0.442 ct: 0.000 0/ 0 ??% ??% ??,?% 3 0
Exiting... (Quit)

paste your mplayer output ...

comment:4 Changed 9 years ago by russianneuromancer@…

You can upload your build of mplayer to sharebee?

MPlayer GIT-ca17d1f-Kovensky-mt 20090822 (C) 2000-2009 MPlayer Team

Playing e:\TrueHD Sample 1 (Final Fantasy VII Advent Children).mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_TRUEHD), -aid 0, -alang und
[mkv] Will play video track 1.
[mkv] No audio track found/wanted.
Matroska file format detected.
VIDEO: [avc1] 1280x720 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Spawning 4 decoding threads...
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [direct3d] 1280x720 => 1280x720 Planar YV12

comment:5 Changed 9 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

Despite an annoying number of messages without -channels 2 it does work for me.
And please use builds from SVN to report bugs here, we can't know what kind of code other MPlayer forks have exactly - better ask wherever you got the build from for help otherwise.

Note: See TracTickets for help on using tickets.