Opened 10 years ago

Closed 10 years ago

#1570 closed defect (invalid)

configure does not properly test x264 / set _ld_x264

Reported by: chrisfriedt@… Owned by: diego@…
Priority: normal Component: build system
Version: 1.0rc2 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The test (in rc2, as of 20090731) will only set _ld_x264 if x264=auto . If x264=yes , then _ld_x264 would never be set.

Please see the supplied patch for a fix.

Attachments (4)

mplayer-1.0_rc2_p20090731-configure-fix-x264-test.patch (1.0 KB) - added by chrisfriedt@… 10 years ago.
configure-fix-x264-test.patch
mplayer-1.0_rc2_p20090731-configure-fix-x264-test.2.patch (862 bytes) - added by chrisfriedt@… 10 years ago.
mplayer-1.0_rc2_p20090731-configure-fix-x264-test.patch
mplayer-1.0_rc2_p20090731-configure-fix-x264-test.3.patch (1.6 KB) - added by chrisfriedt@… 10 years ago.
configure-fix-x264-test.patch
mplayer-1.0_rc2_p20090731-configure-fix-x264-test.4.patch (2.2 KB) - added by chrisfriedt@… 10 years ago.
configure-fix-x264-test.patch

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by chrisfriedt@…

configure-fix-x264-test.patch

comment:1 Changed 10 years ago by chrisfriedt@…

comment:2 Changed 10 years ago by chrisfriedt@…

--- configure_orig 2009-09-18 13:52:31.000000000 +0200
+++ configure 2009-09-18 13:51:38.000000000 +0200
@@ -7176,7 +7176,7 @@


echocheck "x264"

-if test "$_x264" = auto ; then

+if test "$_x264" = auto
test "$_x264" = yes ; then

cat > $TMPC << EOF

#include <inttypes.h>
#include <x264.h>

@@ -7185,10 +7185,22 @@

#endif
int main(void) { x264_encoder_open((void*)0); return 0; }
EOF

  • _x264=no

+ _x264_tmp=no

for _ld_x264 in "-lx264 $_ld_pthread" "-lx264 $_ld_pthread $_ld_lm" ; do

cc_check $_ld_x264 && libs_mencoder="$libs_mencoder $_ld_x264" && _x264_tmp=yes && break

done

+ if test "$_x264" = auto ; then
+ if test "$_x264_tmp" = yes ; then
+ _x264=yes
+ else
+ _x264=no
+ fi
+ else
+ if test "$_x264_tmp" = no ; then
+ die "x264 test failed"
+ fi
+ fi
+fi

if test "$_x264" = yes ; then

def_x264='#define CONFIG_X264 1'

Changed 10 years ago by chrisfriedt@…

mplayer-1.0_rc2_p20090731-configure-fix-x264-test.patch

comment:3 Changed 10 years ago by chrisfriedt@…

  • attachments.isobsolete changed from 0 to 1

(grumble... grumble) stupid attachment editing system...

Changed 10 years ago by chrisfriedt@…

configure-fix-x264-test.patch

comment:4 Changed 10 years ago by chrisfriedt@…

  • attachments.isobsolete changed from 0 to 1

Actually, if _x264_lavc=yes or _x264_lavc=auto, and _x264=yes or _x264=no, then _ld_x264 would additionally not be set for the _x264_lavc test. This patch should fix those cases too.

Changed 10 years ago by chrisfriedt@…

configure-fix-x264-test.patch

comment:5 Changed 10 years ago by chrisfriedt@…

  • attachments.isobsolete changed from 0 to 1

a bit cleaner

comment:6 Changed 10 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

The behaviour is as intended, if you use --enable you are expected to supply the needed linker etc. flags yourself.
This should be documented all over the place, if you think such a documentation is missing at some place, please send a patch to add it.

Note: See TracTickets for help on using tickets.